LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   gift (https://www.linuxquestions.org/questions/linux-software-2/gift-128396/)

skeeleraar 12-23-2003 12:43 PM

gift
 
ive read all about apollon, and decided to get it to (using limewire now), so i download and install gift
no problems there
then i download the other gift files openft, gnutella, fast track, but when i do ./configure, i keep getting this error:

checking for prefix by checking for giftd... no
checking for pkg-config... no
checking for pkg-config... no
*** The pkg-config script could not be found. Make sure it is
*** in your path, or set the PKG_CONFIG environment variable
*** to the full path to pkg-config.
or see "website" to get pkgconfig
configure: error: Library requirements (libgift >= 0.11.1 libgift < 0.12.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

the location of libgift.pc is usr/local/lib/pkgconfig/

i tried
* export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/pkgconfig/libgift.pc
* export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib
* export PKG_CONFIG_PATH=/usr/local/lib
* and i tried by adding export PKG_CONFIG_PATH=/usr/local/lib
export PATH=$PKG_CONFIG_PATH/pkgconfig/libgift.pc
export CLASSPATH=$CLASSPATH
to .bash_profile

but al these without any succes...

anyone got any suggestions on how i can get this to work?

thanks

acid_kewpie 12-23-2003 03:21 PM

just install gift from source, not rpm etc...


All times are GMT -5. The time now is 04:01 PM.