-   Linux - Software (
-   -   Getting the Flash Plugin to work with Chromium in Fedora 11 (

thezerodragon 10-12-2009 04:38 PM

Getting the Flash Plugin to work with Chromium in Fedora 11

Dear Friends,

I switched to Linux in April and haven't looked back since. It's been a great experience, and I owe most of my success to the helpful people here. Sorry if I'm boring you, I just wanted to take a moment to say thanks.

So I recently installed Chromium, but can't view flash videos or games. "No problem", I thought. I remember having to sort it out with Firefox when I first got things running. I looked for some tutorials online, tried every one I could find and nothing has worked. Here are all of the sites I visited, so as to avoid confusion and such.
I went here, but when I used the cp command as root, it said "no such file or directory".

So then I went here:
But when I did the Yum install, it told me I already had the latest version and there was nothing to do. Thus the subsequent commands didn't work.

Ditto with this one: Yum told me the requested package didn't exist.

At this point, I'm beginning to see a pattern, and several of the Ubuntu tutorials said to link the plugin folder for Chromium to the one for Firefox. I managed to do that, successfully, but when I type in

chromium-browser --enable-plugins
it opens a new instance of Chromium (without my theme) but still refuses to play flash videos. I'm sorry, this post must have been almost unbearable to read, but i wanted to be as detailed as possible.

Now what?

reddazz 10-12-2009 08:07 PM

The nightly builds of chromium seem to have plugin support and extensions enabled by default. As long as you have plugins in /usr/lib/mozilla/plugins or /usr/lib/firefox/plugins, chromium should recognise them and use them. You can get the latest build from here.

thezerodragon 10-15-2009 07:52 PM

I feel really stupid asking this, but what do I do with the file once I've unzipped it? How do I run it?

John VV 10-15-2009 11:24 PM

you put it in the plugins folder

"yum install flash-plugin" should have installed it ,if you added the adobe repo
for flash

thezerodragon 10-18-2009 10:10 AM

I have the flash plugin installed. I meant the chromium build. I downloaded it from the website he provided, I just don't know what to do with it afterwards.

scottro11 10-18-2009 03:55 PM

If you're running Fedora, you're best off adding the chromium repo and installing through that.

Afterwards, the command would be

chromium-browser --enable-plugins

You *might* have to copy to /usr/lib/chromium-browser/plugins, or it might work with in /usr/lib/mozilla/plugins.

To enable the repo, here's some instructions.

thezerodragon 10-19-2009 10:23 PM

I really appreciate the help, but I've already gone through that site's instructions with no success.

decodedthought 10-25-2009 04:30 AM

well i am the poster of that article, unfortunately :P
i re-installed Chromium on ubuntu , i didnt need to make any amendments to any file, the flash content is working properly!!

sudo gedit /etc/apt/sources.list
Add the following two lines
deb jaunty main
deb-src jaunty main
save and exit the file

and then sudo apt-get update
and then sudo apt-get install chromium-browser
and after installation the flash just started working normally !! without any tweaking ...

All times are GMT -5. The time now is 07:11 PM.