LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-04-2004, 10:41 PM   #1
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Rep: Reputation: 45
getting rid of interactive mode in MDK 10 howto?


ok, just upgraded my laptop to MDK10 and to be blunt i like RH better, but the question i have is this.

how in the world do i make the stupid interactive mode go AWAY and stay away for things like rm cp mkdri etc???

im sorry, but one of the great things about *nix is when i tell the computer to do something it DOES it without harrasing me 50million times if i really want to do what i told it to do.

if i rm * i want said file gone NOW, not after answereing y or n.

please assist and advise. ty.
 
Old 04-05-2004, 01:09 AM   #2
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
Mandrake has the -i option built into rm and cp. It also has a bunch of similar aliases. If you type 'alias' in your terminal you'll see all of those. You can remove them by using the unalias command (unalias -a for them all). However, I don't know if this is the way to permanently delete them, or if it just works in a single session, as I have never used it myself.
 
Old 04-05-2004, 01:26 AM   #3
mbegovic
Member
 
Registered: Nov 2003
Location: Vancouver, Canada
Distribution: Currently FC3
Posts: 342

Rep: Reputation: 30
BTW, I don't see why this annoys you, buddy. I prefer it this way. I can double check what I'm rm'ing, and that's a good thing in my book.
 
Old 04-05-2004, 01:33 AM   #4
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Just use 'rm -f filename' if you want to delete anything.
 
Old 04-05-2004, 02:48 AM   #5
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
it annoys me when i have to delete 100+ files in a dir that i misplaced and had moved them all already.

i no longer needed them were they were and did not want to waist my time with y+enter 100+ times.

i dont like it in windows either. if i tell the computer to do something i want it done. just me. dont like computers argueing with me.

the -f i take it will get rid of the -i issue?

mbegovic, thank you that unalias worked perfect for getting rid of the -i on rm/cp/mv for me.

thank you very much for the help.

Last edited by Lleb_KCir; 04-05-2004 at 02:51 AM.
 
Old 04-05-2004, 09:16 PM   #6
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
Yes. Adding '-f' worked for me. Because I'm using fedora, by default the is no alias '-i'. I added the the '-i' in my .bashrc myself. But when I think it is safe to delete everything. I just add '-f' option so that the bash won't bother me with interactive mode. (I usually use '-rf').
 
Old 04-05-2004, 10:11 PM   #7
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
ok thank you for the heads up.

fyi, what vs of fedora are you using and how simular is that to the older RH line? i am really missing RH as it runs so much faster on my hardware then MDK does. also runs much lighter then MDK.
 
Old 04-05-2004, 11:01 PM   #8
chii-chan
Member
 
Registered: Sep 2003
Location: chikyuu (E103N6)
Distribution: Redhat 8.0 (2.4.25-custom), Fedora Core 1 (2.4.30-custom)
Posts: 357

Rep: Reputation: 30
older rh releases are faster & smaller . If you have lots of haddisk space and fast computer, Fedora is better.

Last edited by chii-chan; 04-05-2004 at 11:05 PM.
 
Old 04-06-2004, 01:51 AM   #9
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
ok thanks. well i have RH9, so it was the last of the RH release compaired it to MDK10 again latest release of thier software.

installing FedoraC1 now on a desktop to see how i like it compaired to RH9.

im looking for a soild server for my apache and maybe sendmail/postfix(not 100% ill use linux for mailserver yet as im really over my head with that) that will stay up to date for a while to come alowing me to keep it at least errata secure for close to 2yr before i have to OS upgrade.
 
Old 04-10-2004, 02:49 AM   #10
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
Quote:
# .bashrc

# User specific aliases and functions

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
ok that is my .bashrc standard default install with RH9 (MDK10 killed my system so i went back to RH9 as fedoraC1 did not recognise my NIC)

but here is my list of built in aliases:

Quote:
[root@localhost ray]# alias
alias cp='cp -i'
alias l.='ls -d .* --color=tty'
alias ll='ls -l --color=tty'
alias ls='ls --color=tty'
alias mc='. /usr/share/mc/bin/mc-wrapper.sh'
alias mv='mv -i'
alias rm='rm -i'
alias vi='vim'
alias which='alias | /usr/bin/which --tty-only --read-alias --show-dot --show-tilde'
id like premanetly change mv, rm, cp to all without the -i. still getting used to the CLI thing and its hard enough remembering all these new commands without having the dufaule OS screw with the settings like this.

can i just set them back to the .bashrc to rm = rm or is there an other place. there has to be some other file i can edit somehow to resolve this issue. please advise, and help.

thank you.

[edit to add] i can unalias, but that is only good until i logout or i close that counsol so that is not doing what it is supposed to do as i understand it.

Last edited by Lleb_KCir; 04-10-2004 at 02:50 AM.
 
Old 04-21-2004, 03:58 PM   #11
Lleb_KCir
Senior Member
 
Registered: Nov 2003
Location: Orlando FL
Distribution: Debian
Posts: 1,765

Original Poster
Rep: Reputation: 45
still looking for how to make those changes permanet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
howto get rid of Double Rpm's mickeyboa Fedora 5 04-06-2005 05:56 PM
FC2 can not start alone (in non-interactive mode) unsem Fedora 2 11-09-2004 01:59 AM
permanant interactive mode stand Linux - General 1 04-19-2004 06:21 AM
not able to get into interactive mode when linux is booting up? anekkan Linux - Newbie 1 09-06-2003 11:06 PM
SuSE 8.1 - Is there an interactive mode during load? gracecourt Linux - Newbie 3 12-24-2002 11:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration