LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   getting rid of interactive mode in MDK 10 howto? (https://www.linuxquestions.org/questions/linux-software-2/getting-rid-of-interactive-mode-in-mdk-10-howto-166264/)

Lleb_KCir 04-04-2004 09:41 PM

getting rid of interactive mode in MDK 10 howto?
 
ok, just upgraded my laptop to MDK10 and to be blunt i like RH better, but the question i have is this.

how in the world do i make the stupid interactive mode go AWAY and stay away for things like rm cp mkdri etc???

im sorry, but one of the great things about *nix is when i tell the computer to do something it DOES it without harrasing me 50million times if i really want to do what i told it to do.

if i rm * i want said file gone NOW, not after answereing y or n.

please assist and advise. ty.

mbegovic 04-05-2004 12:09 AM

Mandrake has the -i option built into rm and cp. It also has a bunch of similar aliases. If you type 'alias' in your terminal you'll see all of those. You can remove them by using the unalias command (unalias -a for them all). However, I don't know if this is the way to permanently delete them, or if it just works in a single session, as I have never used it myself.

mbegovic 04-05-2004 12:26 AM

BTW, I don't see why this annoys you, buddy. I prefer it this way. I can double check what I'm rm'ing, and that's a good thing in my book.

chii-chan 04-05-2004 12:33 AM

Just use 'rm -f filename' if you want to delete anything.

Lleb_KCir 04-05-2004 01:48 AM

it annoys me when i have to delete 100+ files in a dir that i misplaced and had moved them all already.

i no longer needed them were they were and did not want to waist my time with y+enter 100+ times.

i dont like it in windows either. if i tell the computer to do something i want it done. just me. dont like computers argueing with me.

the -f i take it will get rid of the -i issue?

mbegovic, thank you that unalias worked perfect for getting rid of the -i on rm/cp/mv for me.

thank you very much for the help.

chii-chan 04-05-2004 08:16 PM

Yes. Adding '-f' worked for me. Because I'm using fedora, by default the is no alias '-i'. I added the the '-i' in my .bashrc myself. But when I think it is safe to delete everything. I just add '-f' option so that the bash won't bother me with interactive mode. (I usually use '-rf').

Lleb_KCir 04-05-2004 09:11 PM

ok thank you for the heads up.

fyi, what vs of fedora are you using and how simular is that to the older RH line? i am really missing RH as it runs so much faster on my hardware then MDK does. also runs much lighter then MDK.

chii-chan 04-05-2004 10:01 PM

older rh releases are faster & smaller ;). If you have lots of haddisk space and fast computer, Fedora is better.

Lleb_KCir 04-06-2004 12:51 AM

ok thanks. well i have RH9, so it was the last of the RH release compaired it to MDK10 again latest release of thier software.

installing FedoraC1 now on a desktop to see how i like it compaired to RH9.

im looking for a soild server for my apache and maybe sendmail/postfix(not 100% ill use linux for mailserver yet as im really over my head with that) that will stay up to date for a while to come alowing me to keep it at least errata secure for close to 2yr before i have to OS upgrade.

Lleb_KCir 04-10-2004 01:49 AM

Quote:

# .bashrc

# User specific aliases and functions

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi
ok that is my .bashrc standard default install with RH9 (MDK10 killed my system so i went back to RH9 as fedoraC1 did not recognise my NIC)

but here is my list of built in aliases:

Quote:

[root@localhost ray]# alias
alias cp='cp -i'
alias l.='ls -d .* --color=tty'
alias ll='ls -l --color=tty'
alias ls='ls --color=tty'
alias mc='. /usr/share/mc/bin/mc-wrapper.sh'
alias mv='mv -i'
alias rm='rm -i'
alias vi='vim'
alias which='alias | /usr/bin/which --tty-only --read-alias --show-dot --show-tilde'
id like premanetly change mv, rm, cp to all without the -i. still getting used to the CLI thing and its hard enough remembering all these new commands without having the dufaule OS screw with the settings like this.

can i just set them back to the .bashrc to rm = rm or is there an other place. there has to be some other file i can edit somehow to resolve this issue. please advise, and help.

thank you.

[edit to add] i can unalias, but that is only good until i logout or i close that counsol so that is not doing what it is supposed to do as i understand it.

Lleb_KCir 04-21-2004 02:58 PM

still looking for how to make those changes permanet.


All times are GMT -5. The time now is 03:35 AM.