LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-18-2002, 07:44 AM   #1
kato678
LQ Newbie
 
Registered: Feb 2002
Location: New Hampshire
Distribution: redhat 7.2
Posts: 24

Rep: Reputation: 15
Talking Getting Linux to work on Promise ATA100


Hi. I have ASUS A7v Motherboard and dual boot (or am attempting) Win98/Linux on 2 seperate partitions on 30gig HDD. Using the ATA66 IDE on my motherboard (ASUSA7V has ATA66, and ATA100 IDE's) I can install and run Linux Redhat 7.1 or 7.2 just fine. However, I want to be able to use the ATA100 on my motherboard while in Linux. If I attach my HardDrive to the ATA100 IDE on the MOBO Linux will not boot. I understand that Linux is not "seeing" the ATA100 IDE and i have to feed it the address's or something but I dont know how to do this. Any help would be appreciated


thanks
Lover of Linux and its command line oppurtunities
brian
 
Old 02-18-2002, 10:54 AM   #2
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
OK, so what are you doing?
Are you installing Linux when the harddisk is on one IDE channel, then swapping the harddisk over to the second IDE channel?

Linux recognises the partitions by what channel they're on, regardless of if there are any other devices present. Here is the rundown:

1' Master = hda
1' Slave = hdb
2' Master = hdc
2' Slave = hdd

If you install Linux when the harddisk is on hda, then swapping the harddisk over to hdc is going to cause problems. You could try this:

Have the harddisk on the ATA100 controller. Reinstall RH.

You probably could boot from the CD, enter rescue mode, edit your lilo.conf (or the grub one), and edit your fstab, so that everything points to the correct devices, but it is potentially much harder than just booting from the CD and installing the OS when the harddisk is on the 100 controller.

Keep us posted.
 
Old 02-19-2002, 12:30 AM   #3
kato678
LQ Newbie
 
Registered: Feb 2002
Location: New Hampshire
Distribution: redhat 7.2
Posts: 24

Original Poster
Rep: Reputation: 15
here's what im doing or had done

thanks for responding. When I attempted an ATA100 IDE install of Redhat 7.1 I was on the ATA100 master channel. First It would not install because it could not see that channel for some reason. I had read on the web of someone saying to pass the addresses of the ATA100 IDE to Linux on install which I tried to do. I got some sort of error though when I had began the actual install. Someone else had recommended that I install Linux on the ATA66 and then edit some file to point to the address of the ATA100 IDE.
Im really confused about all this anyways and didnt install Linux since. But now I want to reinstall Linux and learn on the side about it and some C programming so I am going to reinstall it on
a partitioned 30 gig HDD.1st partition will contain WIN98 and second will contain Redhat 7.2. If there is no easy way to install to ATA100 I will just install to ATA66. My main reason for wanting to install to ATA100 was to take advantage of the speed for Vid capture that I do occasionally. If you or anyone knows of a way to install to ATA100 IDE that would be great because I keep running into errors and at this point it being a while I cant remember those errors of hand to write here.


thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Panic at boot from Promise ATA100 w/ Kernel 2.6 MikTheUser Linux - Hardware 9 07-24-2004 02:24 PM
Kernel Panic w/ Promise ATA100 at booting 2.6 MikTheUser Linux - Hardware 1 07-20-2004 03:07 PM
ASUS A7V promise ATA100 boot problem .... purpleburple Linux - General 0 03-29-2003 09:19 PM
Promise ATA100 help purpleburple Linux - General 5 10-09-2002 03:04 PM
RH7 Asus A7V Promise ATA100 - Install & Boot Vectinn Linux - Software 0 04-15-2001 10:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration