-   Linux - Software (
-   -   Getting Java plugin to work on CentOS 5 Linux with Firefox 3.6.x (

MensaWater 08-10-2010 03:03 PM

Getting Java plugin to work on CentOS 5 Linux with Firefox 3.6.x
Just posting this because it was such a bear to find the right answer as so many sites had the wrong one. I'm hoping it might help someone else.

Over the weekend I wanted to install the Java plugin on my Firefox 3.6.8 (as installed directly from Mozilla Firefox download). I followed the instructions at the link below from Java's site:
Which unfortunately were wrong regarding the file to link.
They incorrectly show creating a link under the firefox/plugins directory with:

ln -s <JRE>/plugin/i386/ns7/
On CentOS5 after installing the
ln -s /usr/java/jre1.6.0/plugin/i386/ns7/

I also found that or variations on it in other web pages at Mozilla and around the web.

I finally found the correct file to link in this page:
It shows that instead of the above:
ln -s <JRE>/lib/i386/ .
On CentOS5 that was:
ln -s /usr/java/jre1.6.0/plugin/i386/ .
It even notes at the bottom:

* The classic plugin file was located here:


This file should no longer be used and all symbolic links to it removed.
Other notes from me:
1) You first have to download and install the file from Java's site: jre-6u21-linux-i586-rpm.bin - There is also a non-rpm version if you're not using an rpm based distro.
2) Only JRE 6 update 10 or higher works with Firefox 3.6 or higher. (above is update 21).
3) This worked both with the Firefox 3.6.8 I had installed previously from Firefox download and with the Firefox 3.6.7 rpm installed using yum update with CentOS (the latter comes from the Fedora repository).

EricTRA 08-12-2010 12:19 AM


Thank you for sharing this.

Kind regards,


MensaWater 08-12-2010 03:58 PM

Solved also: Java plugin works for root but not for normal user
As a follow up:

My earlier post did in fact get the Java plugin working for root. However even though the plugin was showing up for my normal (non-root) user account after I did the above it wasn't actually loading java.

I found I had to move my $HOME/.java and $HOME/.mozilla directories out of the way for normal user and let it recreate them when I opened the browser. Prior to doing this however one should backup bookmarks (under Firefox' Bookmarks-->Organize Bookmarks option).

After you do it and pull up Firefox as the normal user you can restore the backed up bookmarks.

Also this loses any Firefox addons (e.g. WOT, AdBlockPlus, Java NoScript) you have for that user so you need to reinstall those after you restart firefox as the normal user. (Note these are addons not plugins - plugins should be OK so long as they are linked in the main firefox/plugins directory as mentioned in my earlier post for Java plugin.)

hcgrant 08-23-2010 05:20 PM

Many many thanks!!!! Ive been messing around off and on for weeks trying to get Java working in Firefox... Kept thinking Id messed up somewhere .
Im using Opensuse 11.1 64 bit btw

PS I didnt have to do the things you mention above .. I just put a symlink into the Firefox plugins directory pointing to as normal user.

buzzybeemarketing 09-10-2010 10:00 PM

Firefox Java Runetime Plugin on centOS 5.5
Here are some tips. By the way, you guys have really helped. What a mess that you have to clean up totally incorrect instructions posted by Sun Java.

1. I was placing the symbolic link to in /usr/lib/mozilla/plugins. Well that's not the correct place. You have to create a plugins directory under (/usr/lib/firefox-3.6/), on my system.

2. Also, I originally installed java with rpm -Uvh jdk-1.6.0_20-fcs.i586.rpm a full all in one package. I had to go back and install update 21 just for the runtime. Then I had to recreate the proper symbolic link to the new runtime update 21.

3. Also, make sure to use the Verify Now link at I was using some other test link that is useless when you don't have java installed yet. At least the first link will give you a firefox missing plugin alert. The other test java site link will not. Don't use That link is useless at first.

bustoutfunk 04-14-2011 07:59 PM

For the super linux impaired...
I am really new to Linux so I thought it would help to put really easy directions (even though it might be redundant).

I performed the following commands:

$ cd /usr/lib/mozilla/plugins
$ sudo ln -s /usr/java/jre1.6.0_24/lib/i386/

Thanks for the posts. This problem has been driving me mad for weeks!

clcbluemont 02-17-2012 11:23 AM

For 64 bit systems
cd /usr/lib64/mozilla/plugins
ln -fs <JRE>/lib/amd64/

donnieblaw 02-27-2012 08:50 PM

I read through all these posts and tried all kinds of symbolic links, but couldn't find any joy. I finally discovered that not all Firefoxes work with all Javas.

To get Java working on Centos 5.5, here's my recipe:

Download and install firefox 10.0. I installed in /usr/local.
Download and install JDK 6u31 (you can just use the jre if you want). I cd to /usr/local before running the self-extracting binary, so it will extract there. If you scroll down on you'll find 6u31.

Verify that the plugin is available:
ls /usr/local/jdk1.6.0_31/jre/lib/i386/


cd .mozilla
mkdir -p plugins
ln -s /usr/local/jdk1.6.0_31/jre/lib/i386/ .

(You have to type a space then a period at the end of the ln command.)
Then restart FF, and you should see Java when you enter the URL


All times are GMT -5. The time now is 02:14 AM.