LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-30-2014, 06:08 AM   #1
Novatian
Senior Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20.3 MATE, Android, Windows 10, MX Linux and Mint 21.1 MATE
Posts: 1,052

Rep: Reputation: 38
Getting Compiz Fusion running?


How does one get Compiz Fusion running?

Which OSs have it?
 
Old 06-30-2014, 10:40 AM   #2
camorri
LQ 5k Club
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 15.0, current, slackware-arm-currnet
Posts: 6,196

Rep: Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844
Quote:
Which OSs have it?
It in the repos for most distros.

Quote:
How does one get Compiz Fusion running?
I would suggest you look here -->http://wiki.compiz.org/

Have a look at this -->http://www.youtube.com/watch?v=VFqj2hS_0iQ

A reasonable overview of how to install.

You need an accelerated graphics card for it to work. See the wiki for more info.
 
Old 09-02-2014, 08:16 AM   #3
Novatian
Senior Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20.3 MATE, Android, Windows 10, MX Linux and Mint 21.1 MATE
Posts: 1,052

Original Poster
Rep: Reputation: 38
OK, in Mint 17 MATE, I have gone to package manager and downloaded Compiz. I think my computer a Dell Inspiron Zino HD has Nvidia and it's own video card memory.

I also downloaded a start Compiz option. But swith it or or not and CCSM options picked, it still does not start up.

I got this reading:
bm-Inspiron-410 bm # compiz check
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Error: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Info: Stopping plugin: core
compiz (core) - Info: Unloading plugin: core

How is this done?
 
Old 09-02-2014, 08:29 AM   #4
camorri
LQ 5k Club
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 15.0, current, slackware-arm-currnet
Posts: 6,196

Rep: Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844
Quote:
Error: Screen 0 on display ":0" already has a window manager; try using the --replace option to replace the current window manager.
You can set up the replace option in CSSM. I'm not near my systems right now to provide better details. I will give you more guidance in a few days when I'm back at my mail system.
 
Old 09-06-2014, 04:13 AM   #5
Novatian
Senior Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20.3 MATE, Android, Windows 10, MX Linux and Mint 21.1 MATE
Posts: 1,052

Original Poster
Rep: Reputation: 38
Hi, I tried looking at the Compiz how to pages and Nixie Pixel's tutorial, but it seems to be hard to find the replace option in CSSM.

Using Mint 17 MATE, 64 bit. Nixie uses Ubuntu, the original.
 
Old 09-06-2014, 07:20 AM   #6
camorri
LQ 5k Club
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 15.0, current, slackware-arm-currnet
Posts: 6,196

Rep: Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844Reputation: 844
Open CCSM. Click on Effects, then click Window Decorations. Make sure you have the Window Decorations box ticked. There is a Command line. Enter 'emerald --replace' without the quotes. Save it. Restart the desktop, Ctrl + Alt + Backspace keys together, should restart the desktop.

It shouldn't matter what distro you are running. Hope this helps.
 
Old 09-06-2014, 06:57 PM   #7
Pedroski
Senior Member
 
Registered: Jan 2002
Location: Nanjing, China
Distribution: Ubuntu 20.04
Posts: 2,112

Rep: Reputation: 73
I am a big fan of compiz. I generally use Ubuntu. You have to download a few extras, but it works seamlessly. I would not like to be without my wobbly windows. Windows that do not wobble are just 19th century. I think that is a fantastic invention for which I would like to publicly thank the authors of compiz.

I cannot get compiz to work with Fedora and Gnome. I think they are incompatible. But if you use KDE or xfce, then compiz will work with Fedora. I changed the snowflake image for an autumn leaf, and then I can have autumn any time on my screen. Does make the cpus run at about 20% though.
 
Old 09-08-2014, 08:01 AM   #8
Novatian
Senior Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20.3 MATE, Android, Windows 10, MX Linux and Mint 21.1 MATE
Posts: 1,052

Original Poster
Rep: Reputation: 38
I got a spin of Fedora from the Fedora site that comes with Compiz, in MATE I think.

I typed in the command emerald --replace and the reply was no such command exists. I also made sure the windows decorations box was ticked.

I even checked in the software package manager for emerald themes... I may have missed.
 
Old 09-10-2014, 05:55 AM   #9
Novatian
Senior Member
 
Registered: Feb 2008
Location: Australia
Distribution: Mint 20.3 MATE, Android, Windows 10, MX Linux and Mint 21.1 MATE
Posts: 1,052

Original Poster
Rep: Reputation: 38
I also typed in a terminal, 0 --replace and 0 is no command either. Should I try windows --replace ?
 
Old 09-23-2014, 11:42 AM   #10
moshebagelfresser
Member
 
Registered: Sep 2005
Location: Rishon Le Ziyyon Israel
Posts: 198

Rep: Reputation: 21
I have Linux Mint 17 Mate installed, compiz --replace command on a desktop launcher wakes up compiz, but what drives me crazy is I have to click it twice to get the panel buttons launcher buttons live. I have installed emerald themes, and set the General in CCM command to emerald --replace. This has given me a nice windows decoration.

I even added to the Startup Programs the compiz --replace command, but if I don't left click the desktop launcher I created, the panel buttons are not live and windows will not have buttons.

I have configured dconf editor desktop sessions required windows desktop to compiz.

I too am at a loss of how to configure compiz to start properly at startup. I have Open GL, Gnome Compatibility and KDE Compatibility ticked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz fusion not working on my laptop running Knoppix muntakem Linux - Laptop and Netbook 1 08-16-2010 06:19 AM
compiz-fusion and fusion-icon problems psilo357 Linux - Software 2 12-22-2008 05:41 PM
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 02:08 PM
howto get compiz-fusion running on debian-etch on intel inbuilt graphics card ? vineet7kumar Linux - Newbie 1 05-03-2008 02:34 PM
Ubuntu+compiz-fusion up and running...how about the sound now! ItsTimeToMoveOn Linux - Newbie 12 01-19-2008 04:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration