LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-26-2016, 01:57 PM   #1
Ciphertext
LQ Newbie
 
Registered: Apr 2016
Posts: 3

Rep: Reputation: Disabled
Get my speakers to work with PulseAudio


Hello dear Linux community,

I finally move from Windows to Fedora and encounter problems setting up my audio devices. Specifically, my speakers won't output any sound, while my headphones do.

I have two separate soundcards installed, one came with my mainboard and the other one was added later via PCI (Asus Xonar DG). Both, my speakers and my headphones work well when attached to the internal soundcard. When using the Xonar DG however, I get neither of them to work. Since the soundcard worked flawlessly in Windows, my assumption is that the configuration of my Xonar DG is not set up correctly. I wanted to kindly ask for help here in this forum.

I tried various speaker volumes just to make sure if there was very silent sound. I also checked twice if I put the audio jack in the correct slot.

Kernel information
Code:
$ uname -r
4.4.7-300.fc23.x86_64
PulseAudio configuration while using Xonar DG as default
Code:
$ pacmd info
...
since the forum won't let me post the whole output, I uploaded it to Pastebin.
http://pastebin.com/raw/rNWPwvGn
 
Old 04-26-2016, 05:58 PM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149
have you installed pavucontrol yet? it is a gui for PulseAudio it allows you to select your input output devices and volume control. that maybe all you need to do.Oh yes, make sure they are not muted. that is a default for most Linux PulseAudio installs. do you have volumeicon or similar applet installed? it will allow you to easily unmute your volume. now that maybe all you need to do.

Last edited by BW-userx; 04-26-2016 at 06:08 PM.
 
Old 04-26-2016, 06:21 PM   #3
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian Stable and Unstable
Posts: 1,943

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
Yes, install pavucontrol, open it, and check all the tabs, making sure that everything is set correctly. You have to select the correct input and output streams, and make sure they aren't muted. Pulseaudio sucks badly, but it's what is available.
 
Old 04-27-2016, 10:20 AM   #4
Ciphertext
LQ Newbie
 
Registered: Apr 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Hello, thanks for your replies.
It seems like I don't have pavucontrol or volumeicon. What I do have though, is a graphical audio configuration interface which already came with KDE. Also, I have an icon in my system tray to mute devices and set volume.

This is what I see in my settings: https://imgur.com/a/0yA3d
Do you think its misconfigured?

Also, when looking through the output of pacmd info, I could not confirm that anything caused my device to be muted.
 
Old 04-27-2016, 03:21 PM   #5
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian Stable and Unstable
Posts: 1,943

Rep: Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538Reputation: 538
I've never used any of those programs, so I don't know if anything is configured properly. You're on your own with KDE, sorry.
 
Old 04-27-2016, 05:47 PM   #6
erik2282
Member
 
Registered: May 2011
Location: Texas
Distribution: debian and centos mostly
Posts: 823

Rep: Reputation: 228Reputation: 228Reputation: 228
Try this.

open a terminal and as a normal user, type in the command:

Code:
erik@mypc:~$ alsamixer
hit enter. select your sound card, if needed, by hitting F6. Use the up and down arrows to lower/higher volume settings. When done simply hit the Esc key.

Last edited by erik2282; 04-27-2016 at 05:48 PM.
 
Old 04-27-2016, 06:25 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149Reputation: 2149
all the above and or select your sound card in that high techy gui thingy then see if that works, if one does not then try the other one. report back
 
Old 04-28-2016, 10:23 AM   #8
Ciphertext
LQ Newbie
 
Registered: Apr 2016
Posts: 3

Original Poster
Rep: Reputation: Disabled
Hello,

in the settings, I pretty much tried out all possible combinations, all profiles.
I ran the alsamixer command and was display a cli gui, where I pressed F6 and selected "Xonar DG". After turning up the volume a bit more, there still was no output.

One strange thing I came across was the fact that as soon as I tried to set anything via terminal, the Device Preference List only showed me one device any more, called "PulseAudio Sound Server". Before doing this, I always have various output devices listed there, including a "Dummy Output".

// EDIT //
I managed to get it working. I found out that my soundcard had the option to connect to the front panel. I was only using the rear panel. So, alsa set the output to front panel only, which caused my rear panel not to receive anything. I ran alsamixer, and changed the 'Analog Output' to 'Multichannel' by using the up and down arrow keys.

Does anybody know how to set this in the shell? KMix has the option to select seperate outputs for my internal soundcard, it doesn't have this option for my Xonar DG though.

Last edited by Ciphertext; 04-28-2016 at 12:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB microphone shows up in pulseaudio but doesn't work adrianmariano Linux - Hardware 19 07-27-2013 09:22 PM
My speakers do not work WantLinuxHelp Linux - Newbie 7 05-05-2012 09:28 AM
[SOLVED] PulseAudio doesn't work after reboot MTK358 Linux - Software 6 08-01-2011 08:33 PM
Microphone doesn't work in Skype with PulseAudio Udi Linux - Software 1 06-20-2010 10:20 PM
Getting speakers to work TheShape75 Linux - General 1 02-22-2002 03:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration