LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-01-2006, 11:00 PM   #1
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Rep: Reputation: 30
Get graphics error messages when I do GLXgears and..


when i run glxgears I get this:

Xlib: extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

and when i try to run blender I get this:

Using Python version 2.3
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
Xlib: extension "GLX" missing on display ":0.0".
ERROR: Unable to open Blender window

? I have no idea what all that means...
 
Old 04-02-2006, 01:06 AM   #2
kg4ysy
Member
 
Registered: May 2005
Location: North Carolina
Distribution: Gentoo
Posts: 123

Rep: Reputation: 19
Look for the module section and make sure glx and dri are listed...if not, put them in and restart your xserver. This should fix the problem.

<MY XORG>
23 Section "Module"
24 Load "dri"
25 Load "dbe"
26 Load "extmod"
27 Load "type1"
28 Load "freetype"
29 Load "glx"
30 EndSection
 
Old 04-02-2006, 09:39 PM   #3
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Section "Module"
dri was not loaded so I changed xorg.conf and I still get the same error.........The error actually specifies glx but it is loaded.

Heres a part of my xorg.conf file.


# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
SubSection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubSection

# This loads the font modules
Load "type1"
# Load "speedo"
Load "freetype"
# Load "xtt"

# This loads the GLX module
Load "glx"
# This loads the DRI module
Load "dri"

endsection
 
Old 04-04-2006, 01:27 PM   #4
M$ISBS
Member
 
Registered: Aug 2003
Posts: 834

Original Poster
Rep: Reputation: 30
Anyone?

I think it may be a problem with Nvidia drivers somehow disappearing
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glxgears error joelescoulie Slackware 3 06-05-2005 01:41 AM
How To Hide Kernel Messages With Graphics dragoncity99 Slackware 3 03-18-2005 08:11 PM
Error with glxgears manikantha Linux - Software 1 03-02-2005 12:28 PM
glxgears libGL error BmxFace Linux - General 0 01-26-2004 12:54 AM
Boot messages without graphics and better resolution sri Linux - General 1 07-10-2003 01:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration