LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-15-2004, 08:40 PM   #1
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Rep: Reputation: 15
Thumbs down Gentoo install problems


Hi, I have just completed a stage 3 gentoo install. After close to 20 attempts to install with problems each time, it all seemed to go fine, apart from etc-update just before rebooting , which had some problem and gave me 3 alternatives which all did nothing and came back to the same menu. So i ctrl+c 'd and continued. After reboot it seemed to boot fine apart from one message saying
Quote:
some failed filesystems failed to mount
Then when I tried to startx I got this error:

_XSERVTransSocketOpen: socket() failed for local
_XSERVTransSocketOpenCOTSServer: Unable to open socket for local
_XSERVTransOpen: transport open failed for local/asylum:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for local

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already running

(An X server isn't already running)

Can anyone help me here, I realy want to get gentoo up and running, but it seems to be out of my league

Thanks
-John

Last edited by johntramp; 04-16-2004 at 03:08 AM.
 
Old 04-16-2004, 03:21 AM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
The "some filesystems failed to mount" error most probably indicates that there is something wrong with your /etc/fstab - the file that tells your system what partitions shoulda be mounted where and how. Technically speaking it could also be because you have not the required file system types in the kernel, but if you followed the instructions to the point it is not likely.

When you fdisk'd your disk(s), did you type the partition names and types down on a note? It can help later when fixing up your /etc/fstab. Or type fdisk -l /dev/hda (where /dev/hda should be replaced by whatever devicename your hard drive has) to get a list of the partition names, sizes and types on a disk.

You could also type cat /etc/mtab (do not edit that file!) to see what filesystems are mounted and compare to your fstab to see what didn't work out. The /boot partition isn't mounted at boot by default on Gentoo (so it shouldn't appear in /etc/mtab, which lists mounted filesystems), and since it's booting you already have that one covered.

Hope that gets you started.


Håkan
 
Old 04-16-2004, 03:42 AM   #3
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
yeah, I added 2 other partitions at /music and /games which are probably the ones not working in boot. Do you have any ideas on the startx problem? I will remove those to partitions and see what happens.
 
Old 04-16-2004, 04:32 AM   #4
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
I removed the /games and /music from /etc/fstab and the error was still there. Here is the mtab and the 2 fdisk drives:

/dev/root / reiserfs rw,noatime 0 0
none /proc proc rw 0 0
none /sys sysfs rw 0 0
none /dev devfs rw 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
none /proc/bus/usb usbfs rw 0 0


Disk /dev/hda: 61.4 GB, 61492838400 bytes
240 heads, 63 sectors/track, 7943 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1028 7771648+ c Win95 FAT32 (LBA) /games
/dev/hda2 1168 7943 51226560 83 Linux /music
/dev/hda3 1029 1167 1050840 82 Linux swap

Partition table entries are not in disk order


Disk /dev/hdb: 8004 MB, 8004132864 bytes
255 heads, 63 sectors/track, 973 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 1 5 40131 83 Linux /boot
/dev/hdb2 6 973 7775460 83 Linux /


I should realy post the /etc/fstab too shouldn't I.
I will need to reboot into gentoo get that, but if anyone can help me out with either of the problems I would appreciate it.
thanks
-John
 
Old 04-16-2004, 06:22 AM   #5
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Yes, the fstab would be nice to compare to what you have posted already.

As for the X error, it seems that perhaps your kernel doesn't support UNIX domain sockets? I was under the impression XFree86 uses TCP/IP sockets but these options should make sure you have both. In the kernel configuration (I use make menuconfig), verify that you have these options enabled:
Go to this location: Device drivers --> Networking support --> Networking options
Check these: Unix domain sockets, Packet socket, and of course TCP/IP Networking.


Håkan
 
Old 04-16-2004, 07:05 AM   #6
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
So can I make menuconfig after i have done what I have already or do I need to start again from scratch?
 
Old 04-16-2004, 07:33 AM   #7
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
this is my fstab:

# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.12 2003/03/11 02:50:53 azarah Exp $
#
# noatime turns of atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail and tail freely.

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hdb1 /boot ext2 noauto,noatime 1 1
/dev/hdb2 / reiserfs noatime,notail 0 0
/dev/hda3 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
#/dev/hda1 /music ext3 noatime 0 0
#/dev/hda2 /win vfat noatime 0 0

# NOTE: The next line is critical for boot!
none /proc proc defaults 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none /dev/shm tmpfs defaults 0 0

Last edited by johntramp; 04-16-2004 at 07:35 AM.
 
Old 04-16-2004, 08:18 AM   #8
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
I get the same error during boot (and my system works fine)... I believe it's because there is no floppy in my floppy drive, and a (removeable) drive won't mount without media. The floppy drive is of course listed in my /etc/fstab by default.

If that's your problem as well, I wouldn't worry about it.

The X problem is more of concern (if you want to use X). I've never seen this error before (so you're clearly trying to use some option that I've never enabled or tried to use), but
hw-tph's suggestion seems a good place to start.

Have you searched the Gentoo forums for more information on this error?
 
Old 04-16-2004, 09:10 AM   #9
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
Ok, thanks - thats good to know. I will sign up for a Gentoo forums account and see if anyone there can help me.
 
Old 04-16-2004, 11:35 PM   #10
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
I have started again from a fresh format, and am up to menuconfig. Those 3 options were enabled be default. Should I enable their sub menus aswell? Also is there anything else I should enable while I am here??
 
Old 04-17-2004, 02:29 AM   #11
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Read the Help for each of the kernel options you want to know about. They usually give you an advisory as to what to do, and the explanations are clear enough that if there's no advisory, you can figure out what to do. If there's no Help for that function, unless I know I need it, I leave it off and have had no problems with that.
 
Old 04-17-2004, 05:11 PM   #12
johntramp
Member
 
Registered: Sep 2003
Location: Christchurch, New Zealand
Distribution: Gentoo / Slackware
Posts: 72

Original Poster
Rep: Reputation: 15
ok i will remember that for next time hopefully that wont be too soon if all goes well
 
Old 09-09-2004, 10:07 AM   #13
lopette
Member
 
Registered: Feb 2004
Location: Switzerland
Distribution: Debian
Posts: 66

Rep: Reputation: 15
same XFree86 problem...

hello all

I've had the same XFree86 problem not being able to open sockets, and it is indeed rare...

All filesystems are mounted correctly, the two networking options are compiled in the kernel, but that doens't help...

I haven't managed to get this working yet, I've tried many different kernel options and none of them work (except using my old kernel, which doesn't let me boot on SATA nor does it recognise eth0 - which kinda sucks doesn't it)

oh, and my distro is debian, so it's not gentoo-specific..

hope you have a clue :-)
 
Old 09-10-2004, 03:35 PM   #14
lopette
Member
 
Registered: Feb 2004
Location: Switzerland
Distribution: Debian
Posts: 66

Rep: Reputation: 15
it works...

yup it does.

I don't really know what I've done (again), compiling the kernel over and over seems to have made it change it's mind. at some point I rebooted (with a kernel I thought I had already tried, with no success) and it worked!

anyway, for the helpful bit, my last .config comes from some website, you can get it here. it's a config that gives you a small and nicely done kernel, you basically just need to set a few things like cpu type, chipset, ethernet and sound card... (and reiserfs support). See the whole how-to on this page but it's in french (I can hear you say "aarghh", you should have paid more attention to what you french teacher said muahaha I can laugh it's my mother tongue)

hope this helps, it has helped me a lot and now my debians run like babes
 
Old 03-23-2005, 06:39 AM   #15
mga78
LQ Newbie
 
Registered: Mar 2005
Location: Switzerland
Distribution: Debian GNU/Linux
Posts: 1

Rep: Reputation: 0
I have found a solution on the startx problem on an other forum:
http://www.debianforum.de/forum/viewtopic.php?p=191568

There is told that Unix domain sockets have to be compiled in the kernel. There it was a kernel 2.6.8 problem and the people had problems if just compiling it as module. The location where to configure it:

/usr/src/linux-"whatever"
make menuconfig
Device Drivers-->Networking support-->Networking options--> <*>

hope this helps
mga
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie gentoo login rfw62 Linux - Software 3 05-02-2005 04:37 PM
Gentoo Newbie Help !!! Best Practices [emerge and stuff...] UsualTuxpect Linux - Software 4 10-13-2004 01:18 PM
Newbie: Gentoo vs. Debian ar1 Linux - Newbie 5 12-04-2003 04:16 AM
Do Gentoo suitable for newbie? Txlyo Linux - Newbie 5 10-12-2003 10:47 PM
Newbie....any one can teach me install Gentoo...? Txlyo Linux - Newbie 1 10-12-2003 04:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration