LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-18-2006, 03:52 AM   #1
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Rep: Reputation: 15
gentoo device initiated services


hi im running gentoo unstable just did the emerge -Du world it works fine only that eth0 is started on boot but i dont have it in rc ,

it says starting device initiated services and it starts so i suppose net.eth0 is being started by something else can anyone tell me where can i edit this so that eth0 does not start on boot?
 
Old 11-18-2006, 08:33 AM   #2
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Gentoo services are started by scripts in /etc/runlevels

The scripts reside in /etc/init.d
They are added or removed from the /etc/runlevels using the "rc-update" command.

If you refer back to the Handbook you will see numerous times where it tells you to add services using this command.

Most likely your Ethernet card is started by the "net.eth0" and it probably is in the /etc/runlevels/default directory ... if so then you can remove the startup service by the following command:
Code:
# rc-update del net.eth0
 
Old 11-18-2006, 10:05 AM   #3
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Original Poster
Rep: Reputation: 15
re

the problem is thar it is not beign started by rc , i do know how to use rc-update the thing is that i dont have net.eth0 in rc and stills starts it but not the way rc will do it when i went to full update to unstable some other program does this cause if i add net.eth0 to rc it starts 2 times in boot one with rc one with the other program , just that i dont know which one is it and how to configure it
 
Old 11-18-2006, 12:44 PM   #4
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
If you have ifplugd (or a similar daemon) ... it could be starting the ethernet interface.

What do you have in your /etc/runlevels/boot and /etc/runlevels/default ?
 
Old 11-18-2006, 01:14 PM   #5
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Original Poster
Rep: Reputation: 15
re

this is my boot and my default directories

matrix runlevels # ls boot/
bootmisc checkroot consolefont keymaps modules rmnologin
checkfs clock hostname localmount net.lo urandom

matrix runlevels # ls default/
acpid alsasound dbus hald ipw3945d local syslog-ng vixie-cron xdm

but i think is something else cause i removed bluetooth from default and now it gets started with net.eth0 in the line in boot that says
starting device initiated services :S
 
Old 11-18-2006, 03:31 PM   #6
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Quote:
Originally Posted by matrixon
matrix runlevels # ls default/
acpid alsasound dbus hald ipw3945d local syslog-ng vixie-cron xdm
Is ipw3945d a service for a Intel wireless card ??
 
Old 11-18-2006, 03:42 PM   #7
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Original Poster
Rep: Reputation: 15
re

yep it is thats my eth1, but i wonder why bluetooth and net.eth0 still booting up :S any ideas?
 
Old 11-27-2006, 03:26 PM   #8
mrodmac
LQ Newbie
 
Registered: Mar 2006
Location: Pennsylvania, USA
Distribution: Arch
Posts: 9

Rep: Reputation: 0
/etc/conf.d/rc

Greetings,

I was having the same issue with my net.eth1 starting. Editing /etc/conf.d/rc and changing the line:

RC_PLUG_SERVICES=""
to
RC_PLUG_SERVICES="!net.*"

solved my issue. Look at the example and I'm sure you'll be able to stop your bluetooth also.

HTH
Rod
 
Old 04-08-2008, 02:41 AM   #9
ade05fr
LQ Newbie
 
Registered: Sep 2007
Location: Metz - France
Distribution: Gentoo
Posts: 16

Rep: Reputation: 0
Question

Hi everyone,

can someone help me ?
i have the same problem with my gentoo(Kernel 2.6.24-r4).
I dont use anymore ipw3945d but instead the integrate module iwl3945 so that means that i have also remove ipw395d from my init script (rc-update -d ipw3945d default) but there is still this ipw3945d module which start with the "device initiated devices : ipw3945d net.lo net.wlan0 udev-postmount"

what can i do for this ?

thank you,
Ade05fr
 
Old 04-09-2008, 09:52 AM   #10
mrodmac
LQ Newbie
 
Registered: Mar 2006
Location: Pennsylvania, USA
Distribution: Arch
Posts: 9

Rep: Reputation: 0
>but there is still this ipw3945d module

Is this a kernel module? I think first off I'd check to make sure there's no reference to it in /etc/modules.autoload.d/kernel-2.6 or /etc/conf.d/net
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to register our own custom services to be initiated at known init level?? mayank_a Linux - Software 2 10-02-2005 09:21 PM
Gentoo: start / stop services Adony Linux - Newbie 5 12-10-2004 10:39 AM
KDE: turn off mouse-initiated desktop switching otbibb Linux - Software 6 10-25-2004 01:52 PM
Xorg, xinitrc not being initiated lukebeales Linux - Software 0 09-14-2004 06:41 AM
shutdown hangs if initiated from Gnome menu halt option jkmin Linux - Newbie 2 02-10-2003 12:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration