-   Linux - Software (
-   -   Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE. (

damien 01-31-2005 11:37 PM

Gentoo 64-bit on AMD. Console sound with ALSA OK, but no sound in KDE.
Hello all,

I'm running Gentoo 64-bit on an Opteron dual-proc. I've looked all through the threads and I can't find a solution. I put this in here because it seems to be what I'm doing with KDE rather than the hardware.

I've got ALSA working from the console fine, aplay happily plays wav files and so on, I can move volume up and down, all that stuff. I can't get a peep out of KDE though. Total silence. I've tried with and without KMixer, and all the different options for Sound & Multimedia in the control panel. No test sound, no CD music, nada. In the Info Centre it can see my sound card (AMD-8111). I can play sounds through aplay from a terminal window within KDE, so it's not being killed completely.

Have I missed something obvious? Any suggestions?


hw-tph 01-31-2005 11:49 PM

I am not a KDE user, but I know KDE applications by default use the arts sound server to output sound. Is it installed, and is it running? If it is but it doesn't seem to work with alsa you may have to re-emerge it with both oss and alsa USE flags set (USE="alsa oss" emerge arts or something to that effect).


damien 02-01-2005 09:17 AM

Hmmm. Arts is there, and the daemon is running. I'll try changing the USE flags. Will I have to rebuild all of KDE, or just arts?


Snipersnest 02-01-2005 09:31 AM

I had a similar issue... it was because one of my outputs was muted in the volume mixer...sound worked fine for me in console also but nothing else...just like yours...have you checked those yet?

damien 02-01-2005 09:50 AM

You mean muted in KMixer (which I think was OK), or is there another one I don't know about?


Snipersnest 02-01-2005 09:52 AM

well yeah...not sure if you have a sound icon by your clock or not...but you can also right click that and open a mixer from there and adjust all your levels.

damien 02-01-2005 10:15 AM

Yeah, that's KMixer. I unmuted everything in there. I can't get to the machine right now, I'll take another swing tonight.


damien 02-02-2005 01:05 AM

Well, I got further. It looks like arts is fighting with alsa. If I disable sound in KDE completely, I can use aplay. If I have arts enabled, no matter which system I use (alsa, oss...) aplay hangs. Anyone got any suggestions?


All times are GMT -5. The time now is 10:20 AM.