LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   GeForce FX 5200, Mandrake 9.1, nVidia Driver trouble - HELP! (https://www.linuxquestions.org/questions/linux-software-2/geforce-fx-5200-mandrake-9-1-nvidia-driver-trouble-help-89376/)

Chrisguy18 09-04-2003 07:26 PM

GeForce FX 5200, Mandrake 9.1, nVidia Driver trouble - HELP!
 
Hi guys,
Let me start by saying that while I'm highly computer literate (hardware/microsoft), i know very, very little about linux.
I decided to give mandrake 9.1 a go, and was pleased when everything seemed to be working fine. I've installed wine, and it works, with limited success, which i kind of expected. I was also pleased that it supported my cd burner. The only thing holding me back from a full conversion from windows xp, is the video performance.


I have a GeForce FX 5200 128MB, Leadtek Winfast. In WinXP, Unreal Tournament 2003 runs excellent at 1024x768, with full quality textures, 2xAA, etc. Looks great. In linux, on the other hand, that basic little game that came with mandrake, called Tux Racer (i think), runs at about 3 or 4 frames per second. I downloaded the nvidia driver for mandrake 9.1 from nvidia.com, and tried to install it. I changes the etc/x11/XF86config 4 file as instructed in the driver readme (i know it's spelt wrong, but you know what i mean). After a reboot, i get my lilo boot menu (as i should). I choose linux, all the normal startup stuff scrolls past (with lots of little green 'OK's :) ). It SEEMS to be just before it enters X that my problems start. My screen flashes between X and a black screen (i'm assuming it's changing resolutions repeatedly), and then i'm faced with a text-based login.

I have no idea how to use a linux terminal! hope somebody knows what's wrong, and how to fix it. Thanks guys.

In case you need this info, my PC:

Athlon XP2600+
MSI K7N2 Delta nForce 2 Chipset
Onboard nForce 2 audio (works ok in Mandrake 9.1)
Onboard LAN
Intel Pro 10/100 Card
SMC 10/100 Card
Surecom 10/100 Card
120GB 8mb Cache WD HDD
Samsung Combo DVD/CDRW
512MB Dual Channel DDR333 (2x256)
128MB Leadtek Winfast Geforce FX 5200

Saraev 09-04-2003 07:36 PM

Ok, you're sitting at the linux terminal, it's asking you to log in. Go ahead and log in as root.

Once you're in, run "startx" which *should* puke. However, when it pukes it should give you some ideas as to why it's puking. See if you can post any of the errors. From there, it could be a typo in the XF86Config file, or could be a driver issue.

DrOzz 09-04-2003 08:02 PM

the error will also be located in your ::
/var/log/xfree86.0.log file ...
look for the line that begins with [EE] which points out errors, and post it here for we can start giving you some options of how to take care of this...

Chrisguy18 09-04-2003 08:23 PM

Thanks for replying so quickly guys. There's one issue: I'm using a school computer (Win 2k) to surf, i don't have the net at home, it's so sad... So: how can i save the error log to a FAT floppy to bring to school to post to you guys?
Also, if i change the "nvidia" back to "nv" in the xf86config file, do you think it will boot into X? if so, how do i change it back from a command prompt?
Thanks heaps!

Chrisguy18 09-04-2003 08:25 PM

... i really am a linux newbie, aren't i?

Saraev 09-04-2003 08:27 PM

1) stick the floppy in the drive. type "mount /mnt/floppy"
2) cp /var/log/xfree86.0.log /mnt/floppy/Xerrorlog
3) umount /mnt/floppy


Also, it's worth a try to change to "nv" for booting, however my FX5200 does run with "nvidia" as the driver. Perhaps while you've got the floppy drive mounted, cp /etc/X11/XF86Config over to the /mnt/floppy/ as well, can make sure there's nothing wrong with that.

Additional: We're all newbies at some point and on some topics. Just keep trying! :)

Chrisguy18 09-04-2003 08:31 PM

Thanks again for your help, and encouragement ;-)
i'm now aspiring to be a linux whiz one day... I'll have that stuff on this post in a few days, keep your eyes peeled!
Thanks!!!

DrOzz 09-04-2003 08:33 PM

yes if it originally worked when using Driver "nv" then if you put it back then yes it will bring you back into X ...
and for the file type::
mount /mnt/floppy <---if that is the mount point, if not change it to what yours is...
cp filename /mnt/floppy

and everyone is a newb at some point :D stick with it, and you'll

Chrisguy18 09-04-2003 08:34 PM

just quickly, how can i edit xf86config to change it back to 'nv'?
thanks

DrOzz 09-04-2003 08:40 PM

well you'll use a text editor....since you are new, i would suggest you use pico, and if it is not installed then you'll have to download a package called pine which is packed with pico...umm, others include -> vi , emacs, joe
i am 99% positve you'll have vi which is very hard for someone that hasn't used it before, but if you read this article that focuses on the installation of the nvidia drivers, you will see they use vi to edit the file, so you'll know the keystrokes to get you by to edit this file and what to edit...
its up to you which you want to use...

Blaa269 01-08-2004 06:18 AM

You might try downloading the current drivers at school for your NVIDIA, all the cards use the same driver file. Your gonna need to install it from outside of XWindows which can be a pain if your new to the Linux Command Line. I had to do this because my GeForce 4 was runng tuxracer that slow to, now everytime I boot the screen flashed the nvidia emblem and works great in any game.

dalek 01-08-2004 08:46 AM

I wrote a little how to for installing the drivers. It is a bit long but good for newbies. Here is a link.

http://www.linuxquestions.org/questions/answers/30

Give that a read. You may want to see if you can get nano. It is a really easy to use editor. I can't remember if it is on the CD or not. It is a small download though if it is not on the CDs.

Later

:study: :D :D :D


All times are GMT -5. The time now is 07:59 PM.