-   Linux - Software (
-   -   gconf error installing python program on mandriva (

crazypig 06-21-2005 03:05 PM

gconf error installing python program on mandriva
I have been trying to install a program called gramps which uses python. Now I'm using a magazine cover DVD Mandriva LE which has python and gramps also on the dvd. i keep getting the following error. i haven't done anything much to my system since installing it so i dont think i've ruined it. Clicking on the rpm invokes Mandrivas installer which starts and then produces this message.

Some package requested cannot be installed:
gramps-1.0.11-1mdk02.i586 (due to unsatisfied gnome-python-gconf(>=1.99])

i click ok and it says 'done' but it hasn't installed. i cant understand the message about the gconf.

Trying to install from the tar.gz it unpacks ok. Then I move into the new directory and then type ./configure
this works until the error ;
checking python bindings for gconf
no module found
gnome-python2-gconf could not be found

essentially, it appears that, either way, i need to change or install this gconf file. This must be obvious to someone but as a newbie, i don't know how to do this or what my changes will effect. Can someone please explain how this is happening on what looked like a straightforward installation?

Thanks in advance, PKM.

tur third 07-26-2005 06:44 AM

I get exactly the same problem when trying to install gramps. I read somewhere that during the install I should have installed both Gnome and KDE desktops, as additional files like these will be installed.

I installed Gnome, but I still get the same problem. I have also tried a few other packages without success.

Does anyone know what we are missing? (preferably a rpm).


crazypig 08-09-2005 09:30 AM

i've not found a solution but theres a similar thread (yours?) on the gramps website :

its not conclusive but may provide a few ideas. one to watch.

All times are GMT -5. The time now is 04:32 AM.