-   Linux - Software (
-   -   Gcc not found in the $PATH (

redrobin77 01-12-2004 09:45 AM

Gcc not found in the $PATH
I get an error like "No C compiler found in $PATH" when I try to run ./configure of many downloaded applications...

this ibviously means I have no cc or gcc..etc in the system . I run redhat 7.3 and I tried to search the installation CD's, but without luck.

Does anyone know where I can get a complete package without having to run into "failed because of missing dependancy" problem ? once and for all... get it downloaded and installed...???

this is taking away the fun of installing games and other applications.....

OR is is a simple case of the path varaible being incomplete ? ( maybe not, since I used the find command to look for gcc but founf nothing..)...

help..!!! :confused:

red robin

trickykid 01-12-2004 10:05 AM

By default in Redhat, it won't install gcc. You should find it available on your cd's though. Usually the second cd or so. Can't remember where exactly as I haven't used Redhat in over several years now.

You can always download it from as well..

redrobin77 01-12-2004 10:09 AM

Is there any way..
Is there any way I can re-install all packages from the CD#2 ? if I find it there ?
The problem I encounter is that if I try to install one .rpm it needs several other .rpm's to have been installed ealier and I go aroung and round...


acid_kewpie 01-12-2004 11:08 AM

you just need to get used to using RPMs. read the sticky thread at the top of the Linux - General forum for info about installing RPM's. Indeed, any "beginners guide" would do just as well.

All times are GMT -5. The time now is 01:21 PM.