-   Linux - Software (
-   -   gcc-gnat depends on OLDER version - pls help! (

emmalg 06-04-2009 10:47 AM

gcc-gnat depends on OLDER version - pls help!
I am running Fedora 10 and have been trying to install gcc 3.4.6 from source including ada language support as I require to run some 3rd part software for work.

Unfortunately whilst gcc needs any cc or gcc installation (I have 4.3), GNAT appears to depend on compiling it with **older** versions, as I can see from the bug report at:

It first fell over with the following warning which is treated as an error and causes an exit:


a-elchha.adb:103:13: warning: index for "Buff" may assume lower bound of 1
a-elchha.adb:103:13: warning: suggested replacement: "Buff'First"

I made the recommended substitution but the next attampt at compiling gave:

Code: package "System.Exceptions" does not allow a body remove incorrect body in file "s-except.adb"

Whilst I don't know any ada at all, this type of warning suggests to me that the syntax of System.Exceptions has changed significantly and I doubt I can work around this one.

Unfortunately the Fedora 10 "compatability gcc 3.4" package doesn't contain the gnat support either which is why I was resorting to the source.

Please can someone advise me how I can proceed, as far as I can see I have the following options:

1) Find an older pre-compiled version of gnat that will work on Fedora 10
2) Find a way to edit the offending file and each of the others that will pop up afterwards (this is only the 13th file out of LOADS to be compiled).
3) Install gcc without the ada support and borrow a library compiled for RedHat WS4 which has been offered to me.

Have a better day I am! :-)

Valery Reznic 06-04-2009 08:25 PM

You can install older distro which has gcc-3.4 as THE compiler (what it was - FC 3 ?) in VM or the other physical box, built libgnat-3.4 on this distro and then copy it to your Fedora 10 box.
While tedious it should work :)

emmalg 06-05-2009 04:30 AM

Hi Valery

Thanks for the suggestion, I think I'll give it a try. I've actually already asked the IT dept if they had any old disks lying around so I could install all the software on a legacy OS which comes with compiler!

You wouldn't think it, but the software I am trying to run is a recent release!


lazlow 06-05-2009 07:08 PM

There are a few packages made to handle this situation.


emmalg 06-08-2009 04:37 AM

Hi Lazlow

I had those packages installed originally, unfortunately it didn't look like there was any ada support built into the packages. The required library was still missing so I couldn't run the software.


emmalg 06-16-2009 08:56 AM

Was eventually pointed to a really old gcc 2.5 package and started from that. For more (very brief) info, see:

All times are GMT -5. The time now is 09:18 PM.