LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-29-2004, 05:15 PM   #1
Maxxer
LQ Newbie
 
Registered: Mar 2004
Location: Moggio (it)
Distribution: Debian / RedHat
Posts: 10

Rep: Reputation: 0
Gammu and Nokia 7250


Hi

I've problems with Gammu and a PL2303 data cable.

How can I know if the cable is well recognized by my system?
My log/messages:
kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered
for Generic
kernel: usbcore: registered new driver usbserial
kernel: drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
kernel: drivers/usb/serial/usb-serial.c: USB Serial support registered
for PL-2303
kernel: pl2303 1-1:1.0: PL-2303 converter detected
kernel: usb 1-1: PL-2303 converter now attached to ttyUSB0 (or
usb/tts/0 for devfs)
kernel: usbcore: registered new driver pl2303
kernel: drivers/usb/serial/pl2303.c: Prolific PL2303 USB to serial
adaptor driver v0.10

# ls -l /dev/ttyUSB0
crw-rw-r-- 1 root dialout 188, 0 2004-09-27 23:22 /dev/ttyUSB0

# lsusb
Bus 001 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

As I saw in other websites the cable seems to be detected.

# cat .gammurc
[gammu]
port = /dev/ttyUSB0
connection = fbuspl2303
model = 7250

but if I run
# gammu textall --identify
[Gammu - version 0.98.0 built 12:39:54 Sep 9 2004]
[Connection - "fbuspl2303"]
[Model type - "7250"]
[Device - "/dev/ttyUSB0"]
[OS/compiler - Linux, kernel 2.6.7, gcc 3.3]
[Module -
"1100|1100a|1100b|3100|3100b|3108|3200|3200a|3300|3510|3510i|3530|3589i|3590|3595|5100|5140|6100|620 0|6220|6230|6310|6310i|6385|6510|6610|6610i|6800|7210|7250|7250i|7600|8310|8390|8910|8910i"]
Setting speed to 19200
Setting speed to 115200
SENDING frame type 0x10/length 0x0C/12
00 |01 |00 |10 |07 |01 |02 |06 |0A |14 |17 |399 ...........9
Getting model
SENDING frame type 0xD1/length 0x05/5
00 |01 |00 |03 |00 .....
[Retrying 1 type 0xD1]
SENDING frame type 0xD1/length 0x05/5
00 |01 |00 |03 |00 .....
[Retrying 2 type 0xD1]
SENDING frame type 0xD1/length 0x05/5
00 |01 |00 |03 |00 .....
[ERROR 14: No response in specified timeout. Probably phone not connected.]

I tried with a lot of Nokia models but noone works, always timeout.
How do I know if the /dev/ttyUSB0 device was created correctly (this
is one of the things I think may be wrong)? How do I know if it's a
cable/phone/conf problem?
Thanks
Maxxer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gammu Won't Open...mysql Error jumpoutawindows Linux - Software 1 02-28-2005 12:06 AM
gammu with Nokia 7710 adityavpratap Linux - Laptop and Netbook 0 02-22-2005 06:53 AM
wammu and gammu help damienduff Linux - Software 2 02-14-2005 11:01 PM
Nokia 7250 on MDK 9.2 Psychosoft Linux - Hardware 0 04-12-2004 05:48 AM
Nokia 3300 meto Linux - Hardware 0 12-25-2003 02:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration