LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-23-2003, 03:59 AM   #1
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Rep: Reputation: 30
Gaim Installation Problems...


Ok, when I went to install gaim the first time (i haven't gotten past the ./configure script yet..) it said i didn't have a new enough version of glib, so i grabbed the latest and installed it, now its wanting a newer version of gtk+, but when i goto install that, its saying this:

Code:
checking for pkg-configue... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.1.4 atk >=1.0.1 pango >= 1.0.1... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing 'atk.pc' to the PKG_CONFIG_PATH environment variable.
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.1.4 atk >=1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

there you have it....well, now i can't find the 'atk' package so i can install it and hopefully install gtk...godamn, how many dependencies does Gaim have?!?!!

btw, dist is slack 8.1...im guessing its got a few old packages now...

Edit: also, the copy of Gaim i have is the night build...could that be contributing to it?

Last edited by Grim Reaper; 02-23-2003 at 04:08 AM.
 
Old 02-23-2003, 08:28 AM   #2
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
Compile GTK+2.2 in first. I guess the developers just assume everyone already has it.
 
Old 02-23-2003, 08:29 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
you'll need the -devel pacakges for this, not just the lbraries itself as you are compiling from source.
 
Old 02-24-2003, 02:47 AM   #4
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Original Poster
Rep: Reputation: 30
Allen614, err, what do you mean...thats what im trying to do right now. I'm trying to compile GTK+2.2.1 because thats what gaim is now asking for (its gotten past the glib error...)...

acid_kewpie, -devel package for gtk+ or gaim...got any links there?...what exactly is the -devel package anyways?
 
Old 02-24-2003, 09:22 AM   #5
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
In a root term "ldconfig" or check your /etc/ld.conf.so and add your PATH to your libs.
 
Old 02-25-2003, 02:18 AM   #6
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Original Poster
Rep: Reputation: 30
Allen614, yeah, ive run ldconfig and tried to do ./configure for gtk+ again, no go...my /etc/ld.conf.so has this in it:

/usr/local/lib
/usr/X11R6/lib
/use/i386-slackware-linux/lib
/lib

but i still get the
Code:
checking for pkg-configue... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.1.4 atk >=1.0.1 pango >= 1.0.1... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing 'atk.pc' to the PKG_CONFIG_PATH environment variable.
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.1.4 atk >=1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
error message....any more idea's? pleasssssseeeeeeeeee
 
Old 02-25-2003, 03:43 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
ideas? INSTALL THE DEVEL PACKAGES!!!!!

1) take name of package
2) add -devel to the end of it
3) download it from rpmfind.net
4) install it
 
Old 02-25-2003, 04:03 AM   #8
Allen614
Member
 
Registered: Dec 2002
Location: Plains
Distribution: Slackware 13
Posts: 465

Rep: Reputation: 30
You might look this page over if you haven't already.

http://developer.gnome.org/doc/API/2...-building.html

Here's my ld.so.conf.

/usr/local/lib
/usr/X11R6/lib
/usr/i386-slackware-linux/lib
/opt/kde/lib
/usr/lib/qt/lib


Last edited by Allen614; 02-25-2003 at 04:07 AM.
 
Old 02-25-2003, 05:01 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
i can utterly promise you that this has nothing whatsoever to library paths. nothing.
 
Old 02-25-2003, 05:28 AM   #10
Grim Reaper
Member
 
Registered: Apr 2002
Distribution: Gentoo 2006.0 AMD64
Posts: 399

Original Poster
Rep: Reputation: 30
w00t, got it going. I guess the CVS version doesn't like me, just grabbed the stable version and off she went


Edit: acid_kewpie, i asked you what you meant by that, but got NO response!!! Settle down a tad. It's going now with the stable version, i just wanted to see if anything new was in the CVS version, i guess ill have to wait until the new stable version is released.

Last edited by Grim Reaper; 02-25-2003 at 06:25 AM.
 
Old 02-25-2003, 01:05 PM   #11
Cage47
Member
 
Registered: Feb 2003
Location: Pasadena, TX
Distribution: Debian Lenny
Posts: 220

Rep: Reputation: 31
So the latest stable version of GAIM will compile ok on Debian, huh? I was wondering that. I had a similar post when you had yours. Oh and I received a not so pleasent remark from kewpie also. Don't know what his problem is today.

Oh, do you use a webcam with that, or actually do you view IM Imaging with it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help with installation of gaim pharmd Linux - Newbie 3 02-28-2005 11:23 AM
Problems: Gaim 1.x.x installation on Red Had 9.0 ctrl Linux - Software 0 12-08-2004 08:53 PM
GAIM 0.75 installation problems GaijinPunch Linux - Software 1 03-01-2004 09:39 PM
GAIM installation problems Ryknow215 Linux - Software 1 01-23-2004 03:25 PM
Gaim/MSN protocols and problems upgrading Gaim and Kopete. sergeantroach Linux - Software 5 11-01-2003 09:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration