-   Linux - Software (
-   -   Gaim 0.71: pkg-config finds 2.2.3, ./configure finds 2.2.1 (

GreenPenInc 10-22-2003 08:58 PM

Gaim 0.71: pkg-config finds 2.2.3, ./configure finds 2.2.1
I'm trying to install Gaim 0.71, but I'm getting this error:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at

It seems rather odd to me. First, it says that GLIB 2.2.1 is "found" but it doesn't say where. I used find but couldn't find it. I see that I'm not the first person to get this error, but I believe the other gentleman's solution involved rpm files or prepackaged packages, and I prefer to install from source. I researched LD_LIBRARY_PATH but I found that it was "bad" to set this, so I'd rather not mess with it. And as for editing /etc/, I have that file but I don't know what to do with it. Here are its contents:



I presume I'm to add a link of some sort to the file, but I'm not sure how to do that and, since I don't know where GLIB is installed anyway it's hard for me to do that. I appreciate any help you can give!

misophist 10-23-2003 01:51 AM

Did you try to use synaptic? If Gaim is available, and I'm pretty sure it is, that's the method of choice for you.

the command to locate it would be 'locate glib'. You probably have it.

GreenPenInc 10-23-2003 07:49 PM

Thanks for your help!

I've decided to forgo gaim for the time being and try kopete, but I think the underlying glib problem ought to be addressed. Any application requiring it still comes up with 2.2.3 and 2.2.1, and I still don't know where 2.2.1 would be found. I tried locate glib, but it returned nothing.

misophist 10-23-2003 08:00 PM

SuSE has glib 1.2 in /usr/include/glib-1.2 and /usr/lib/glib. It may net be possible to have two versions installed without more savvy than I have.

I just did an update so SuSE doesn't supply the latest version.

All times are GMT -5. The time now is 03:03 PM.