LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   g++2.96 ?? (https://www.linuxquestions.org/questions/linux-software-2/g-2-96-a-465862/)

wahaha 07-20-2006 06:35 AM

g++2.96 ??
 
Halo... i had found out one link as below:
http://wirelessafrica.meraka.org.za/...hp/Mobile_Mesh

May i know how to check the version of g++ in fedora core 4 ??

Nylex 07-20-2006 07:10 AM

"g++ -v" will tell you the version you're using.

wahaha 07-21-2006 12:20 AM

halo...if i want to install the g++ 2.96 compiler and libraries as stated in above link, what should i type the command in fedora core 4, 2.6.11-1.1369_FC4 ?

Is it " yum install <package> " ? If there is any specific commands please let me know. Thx :D

Nylex 07-21-2006 01:11 AM

I don't know, check yum's man page.

wahaha 07-21-2006 11:14 AM

halo ... i have download the g++ 2.96 from this link as below :
http://rpm.pbone.net/index.php3/stat....i386.rpm.html

But when i tried to install it, error message appears such as below :

[root@localhost Desktop]# rpm -Uvh gcc-2.96-69.i386.rpm
error: Failed dependencies:
cpp = 2.96 is needed by gcc-2.96-69.i386
gcc < 2.96-79 conflicts with glibc-devel-2.3.5-10.i386
gcc = 4.0.0-8 is needed by (installed) gcc-java-4.0.0-8.i386
gcc = 4.0.0-8 is needed by (installed) gcc-c++-4.0.0-8.i386
gcc = 4.0.0-8 is needed by (installed) gcc-gfortran-4.0.0-8.i386
gcc = 4.0.0-8 is needed by (installed) gcc-gnat-4.0.0-8.i386
gcc = 4.0.0-8 is needed by (installed) gcc-objc-4.0.0-8.i386
gcc = 4.0.0 is needed by (installed) libtool-1.5.16.multilib2-1.i386
gcc = 4.0.0 is needed by (installed) apr-devel-0.9.6-3.i386
gcc = 4.0.0-8 is needed by (installed) libmudflap-devel-4.0.0-8.i386

When i tried to download the cpp -2.96-69.i386.rpm from below link:

http://rpm.pbone.net/index.php3?stat...96-69.i386.rpm

The error message appear as :

error: Failed dependencies:
cpp = 4.0.0-8 is needed by (installed) gcc-4.0.0-8.i386

May i know why it is still related to my current version g++4.0.0 ?

Did anyone know how to solve the problem ??


All times are GMT -5. The time now is 07:31 AM.