-   Linux - Software (
-   -   Fuse installation problems: "cannot remove `/sbin/mount.fuse': Permission denied" (

kvm1983 02-02-2012 11:52 AM

Fuse installation problems: "cannot remove `/sbin/mount.fuse': Permission denied"
I am trying to install FUSE in my home dir since I do not have root access to the system I am working on. (FUSE is installed on this system but its libraries are not)

During `make install`, I get the following error:
libtool: install: /usr/bin/install -c fusermount /home/gabriel/opt/fuse-2.8.7/installation/bin/fusermount
libtool: install: /usr/bin/install -c ulockmgr_server /home/gabriel/opt/fuse-2.8.7/installation/bin/ulockmgr_server
/bin/mkdir -p /sbin
/usr/bin/install -c ./mount.fuse /sbin/mount.fuse
/usr/bin/install: cannot remove `/sbin/mount.fuse': Permission denied
make[2]: *** [install-exec-local] Error 1
make[2]: Leaving directory `/home/h2/gabriel/opt/fuse-2.8.7/util'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/home/h2/gabriel/opt/fuse-2.8.7/util'
make: *** [install-recursive] Error 1

I have configured it using --prefix={HOME}/opt/fuse/installation, and most of the files rightly go in this directory, but it tries to install mount.fuse to /sbin. I even manually modified the Makefile to change the location of the MOUNT_FUSE_PATH variable (which was set to /sbin for some reason), but I still get the same error.

Specs: SUSE Enterprise Linux, FUSE 2.8.7

Thanks for your help.

John VV 02-03-2012 09:07 PM

i would have the system administrator run

su -
zypper in fuse fuse-devel

or do you also need "gvfs-fuse " or "zfs-fuse"


FUSE is installed on this system but its libraries are not
"libfuse2" is required by gvfs-fuse
odd it should be installed

su -
zypper in gvfs-fuse  libfuse2

from your error

/usr/bin/install: cannot remove `/sbin/mount.fuse': Permission denied
if you do not have root permission you can NOT remove a system file

have the System Admin. do that.

unSpawn 02-03-2012 09:53 PM

...and if the SA doesn't install FUSE there'll be no setuid root fusermount binary and you won't be able to mount FUSE file systems.

kvm1983 02-05-2012 11:34 PM

So I *will* need root access to install fuse. It cannot be installed by a non-root user.
Thanks for your help.

All times are GMT -5. The time now is 07:35 PM.