-   Linux - Software (
-   -   fullscreen (SDL?) problems (stretchy/blurry fading/blank) (

taids 06-29-2004 07:57 AM

fullscreen (SDL?) problems (stretchy/blurry fading/blank)
The problem:

Recently, I was fortunate enough to get DRI working with the ATI Radeon IGP (320M) on my laptop -- it required lots of compiling (recompile of X, switch from to XFree, etc). I get very high FPS in most 3D/video now comparitavily to non-DRI, e.g. screensavers run at 30-60fps as opposed to 2-5fps, and video doesn't loose sync (with sound) in Mplayer.

I'm having a few issues though, and I think its related to SDL. When I run an application that uses SDL in fullscreen, the screen sort of fades to black -- the effect is hard to describe, it's like ice/condensation freezing over on a window, I guess. I've noticed though, that the screen isn't completely blank, if I move the mouse round, I can see it stretched the full length of the screen in places (vertically), and in other places it completely disappears. Whatever I'm trying to view isn't on the screen either.

I was having mixed results trying to use the Quake 3 demo, if I ran it in a resolution lower than 640x480 (fullscreen), I would get the same problem as with other fullscreen (SDL?) apps. If I ran it in 800x600, the screen would be mostly filled, with the right side of the screen being really distorted and stretched. 1024x768 (the max res of my laptop screen) was totally fine.

The SDL test apps run perfectly in (their default) windowed mode, but when run in fullscreen (with the -fullscreen parameter), the problem again occurs.

What I've tried:

Recompiling/upgrading SDL. By doing this, Q3 demo seems to have stopped displaying properly at all. Even in windowed mode.

I've tried installing GGI and recompiling SVGAlib and then enabling support for them in SDL, and then using those as the video driver -- svgalib doesn't seem to work, and GGI gave funny colours

I've edited my XFree config to specify on the resolution used by my screen, as well as several resolutions -- this didn't seem to have any impact on it

The solution?:

I assume to sort the problem I need to get SDL to use the resolution of my screen, because at the moment it looks like its putting the image off screen, then waaay over stretching it onto the viewable area of the screen

The specs for the graphics are ATI Radeon IGP (320M) 64MB (shared), 14" laptop panel screen, HP/Compaq NX9005, running Slackware 9.1, 2.6.6 kernel, XFree 4.4, DRI build from CVS few weeks old...

Any ideas/suggestions? (Thanks in advance too)

taids 06-29-2004 11:59 AM

Hmm, I just updated the kernel to 2.6.7, recompiled the DRI kernel module, rebooted, and it appears that full screen mode works in most things! All the SDL test apps work in fullscreen and so do the other fullscreen apps, however, Q3 is still ballsed up...

One step closer...

Edit: randomly, q3 now works again, windowed and fullscreen, and all fullscreen modes scale properly.

Nitrox 11-07-2004 09:29 PM

If you dont mind me asking...

What kind of FPS are you showing with glxgears on your IGP 320m ??
I'm actually getting less with 3d accelration enabled.
And its obvious. From 300 to 166.

taids 11-08-2004 02:36 AM

Goodness! This is an old thread!

I've recently installed dropline Gnome 2.8 and that completely broke my X install, complaining that certain modules in my config didn't exist, and it couldn't find modules such as the keyboard (any idea?). This lead to me recompling XFree86 and installing that (which I normally have to do, since doesn't support the 320m for DRI, aparently?)

I'm sure GLX gears was showing something like 900 FPS when DRI was working, but sadly, at the moment, it's broken again.

What config are you using with it? I mean modules, kernel, X build, etc.

Nitrox 11-08-2004 02:59 AM

Thanks for responding.....

Ive tried numerous things for months.
What finally worked was a 2.4.26 kernel and a fresh install of Xorg 6.8.1.

AGPGART is compiled into the kernel.
Radeon is a module.
GLXinfo shows Direct rendering: yes.

Now when I install the new DRI snapshot .... radeon20041106-i386.tar.gz, I get
about 308 with glxinfo saying Direct rendering: no. Which to me means that
3d acceleration is disabled.

There are no errors in my Xorg.0.log that I can tell, except for the failure to recognize a
second screen. My xorg.conf has a few options, I tried with them and without.
Same results...

Section "Device"
Identifier "Video1"
Driver "radeon"
VendorName "ATI"
BoardName "Radeon Mobility U2"
VideoRam 65536
BusID "PCI:1:5:0"
Option "AGPMode" "4"
Option "DPMS"
Option "AGPFastWrite" "On"
Option "EnablePageFlip" "On"

All times are GMT -5. The time now is 07:20 AM.