LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2003, 09:20 PM   #1
supermax
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.1
Posts: 40

Rep: Reputation: 15
ftp config


Hi,

I downloaded vsftpd but I can't find any program to use it, when I try to run it, it say it does not run standaole, must be started from inetd. Any suggestion?
 
Old 08-05-2003, 10:30 PM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
RHL 9 - its using xinetd. Redhat ships vsftpd. The RHL 9 version can be a stand alone server or an xinetd controlled service.

If you need to start it with xinetd:

1. check /etc/vsftpd/vsftpd.conf and make sure this is commented:

listen=YES -> put a # to disable

2. Create a vsftpd file under /etc/xinetd.d/ with lines likes this:

# default: off
# description: The vsftpd FTP server serves FTP connections. It uses \
# normal, unencrypted usernames and passwords for authentication.
service ftp
{
socket_type = stream
wait = no
user = root
server = /usr/sbin/vsftpd
nice = 10
disable = no
flags = IPv4
}

then restart xinetd:

/sbin/service xinetd restart

You need to be root to do these.

hth.
 
Old 08-05-2003, 10:36 PM   #3
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
So get inetd to start it for you!

As root, edit /etc/inetd so that inetd starts it for you.
Add a line

ftp stream tcp nowait root /usr/sbin/tcpd /usr/sbin/vsftpd

and any command line arguments it needs as appropriate
and restart the server with

/etc/init.d/inetd restart

BUT since you are using RedHat9 (or so you claim in your sidebar info), are you not running xinetd?

Then as root, create the file in /etc/xinetd.d/vsftpd with the following contents

#*****************************************************************************#
#
# file : /etc/xinetd.d/vsftpd
#
#*---------------------------------------------------------------------------*#
#
# description : The vsftpd FTP server serves FTP connections. It uses
# unencrypted username and password pairs for authentication.
#
service ftp
{
bind = <insert your IP address here>
disable = no
flags = REUSE
nice = 10
server = /usr/sbin/vsftpd
server_args = <add appropriate command line arguments here or delete this line>
socket_type = stream
user = root
wait = no
}
#
#*****************************************************************************#

Then restart the server with

# /etc/init.d/xinetd restart

Not too difficult?
 
Old 08-06-2003, 05:35 PM   #4
supermax
Member
 
Registered: Aug 2003
Distribution: Mandrake 9.1
Posts: 40

Original Poster
Rep: Reputation: 15
I did it but still refuse connections....

[root@localhost root]# ftp 127.0.0.1
Connected to 127.0.0.1 (127.0.0.1).
500 OOPS: vsftpd: too many arguments (I take an optional config file only)

And my config file:
#*****************************************************************************#
#
# file : /etc/xinetd.d/vsftpd
#
#*---------------------------------------------------------------------------*#
#
# description : The vsftpd FTP server serves FTP connections. It uses
# unencrypted username and password pairs for authentication.
#
service ftp
{
bind = 127.0.0.1
disable = no
flags = REUSE
nice = 10
server = /usr/sbin/vsftpd
socket_type = stream
user = root
wait = no
}
#
#*****************************************************************************#

thanks for any help
 
Old 08-06-2003, 09:04 PM   #5
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
From /usr/share/doc/xinetd-2.3.11/CHANGELOG

---------------------------------------------------------------------------------
CHANGELOG: All services now essentially default to having the REUSE flag.
CHANGELOG: The -reuse option and the REUSE flag are now silently ignored.
--------------------------------------------------------------------------------

I missed that one, so remove the

FLAGS=REUSE

line and trying again.

Please let post if that works or not (including error message).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP Server Config Issue blainehilton Linux - Software 3 07-05-2005 07:13 PM
FTP config problems maximyus Linux - Networking 2 01-06-2005 11:52 PM
Apache2 + SuSE 9.1 + FTP = how to config? spankmeister7 Linux - Software 0 07-25-2004 06:46 PM
About Proftpd ftp server config tommyliu Linux - Newbie 2 06-13-2004 11:39 AM
config ftp jetfreggel Linux - Newbie 4 08-09-2002 12:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration