LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-02-2004, 01:24 AM   #1
craigers
LQ Newbie
 
Registered: Jun 2004
Location: Wisconsin
Distribution: Mandrake Linux 10
Posts: 20

Rep: Reputation: 0
fstab edit


how do i edit my fstab so i have read/write access to my windows ntfs drive (i only have read permission now). thanks
 
Old 12-02-2004, 01:28 AM   #2
hostprotect
Member
 
Registered: Nov 2004
Posts: 56

Rep: Reputation: 15
if it were /dev/hda1 try

/dev/hda1 /path/to/mount ntfs umask=002,ro,users 0 0


Make sure your kernel has ntfs support.
 
Old 12-02-2004, 02:57 AM   #3
shmonkey
Member
 
Registered: Nov 2004
Location: UK
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
Shouldn't it be rw instead of ro ?
 
Old 12-02-2004, 05:25 AM   #4
kees-jan
Member
 
Registered: Sep 2004
Distribution: Debian, Ubuntu, BeatrIX, OpenWRT
Posts: 273

Rep: Reputation: 30
As far as I know write support for ntfs is not supported. rw won't help much

Groetjes,

Kees-Jan
 
Old 12-02-2004, 05:39 AM   #5
binumvk
LQ Newbie
 
Registered: Mar 2004
Location: India
Posts: 24

Rep: Reputation: 15
ntfs is there but we want to recomile the kernel with ntfs support
 
Old 12-02-2004, 06:12 AM   #6
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
If NTFS is there, why do you want to recompile?

You will not get write support, only overwrite support (it is not possible to delete, create or modify the filesize). Real write support is not availlable from kernel NTFS. Only captive-ntfs and some commercial tools allow NTFS write.

This is the information I got from previous threads on this topic.
 
Old 12-02-2004, 06:22 AM   #7
binumvk
LQ Newbie
 
Registered: Mar 2004
Location: India
Posts: 24

Rep: Reputation: 15
Question

But in default it is compiled without ntfs support , so u want to recomiple it.

Ntfs write support is there u can compile kernel with that option,But it is dangerous
 
Old 12-02-2004, 06:38 AM   #8
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
binumvk:
Sorry, there was some missunderstanding. I thought you were talking about something you intended to do that was already done. I understood "ntfs support is there and I want to recompile the kernel to get ntfs support", just a semantic problem

BTW: the 'default' is different in various distros. In SuSE NTFS is compiled per default. However, write support is always turned off (per default).

And just for curiosity: did you ever try to write files on NTFS partitions? Are we talking about NTFS in kernel 2.6?
 
Old 12-02-2004, 10:08 AM   #9
kadhan
Member
 
Registered: Dec 2004
Posts: 40

Rep: Reputation: 15
i'm a beginner in linux.so please help me.i'm usin fedora core 1.i cannot write 2 my vfat partitions as a user,but can write as root?what should i do to get r/w access.how fstab should b edited?
 
Old 12-02-2004, 10:12 AM   #10
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
Please post your /etc/fstab, so we can see what might be wrong.

In general it could be a missing umask option. See example in post#2.
 
Old 12-02-2004, 10:38 AM   #11
kadhan
Member
 
Registered: Dec 2004
Posts: 40

Rep: Reputation: 15
here is my etc/fstab
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda10 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/hda1 /mnt/c vfat defaults 0 0
/dev/hda5 /mnt/d vfat defaults 0 0
/dev/hda6 /mnt/e vfat defaults 0 0
/dev/hda7 /mnt/f vfat defaults 0 0
/dev/hda8 /mnt/g vfat defaults 0 0
please help me
 
Old 12-02-2004, 10:43 AM   #12
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: Ubuntu
Posts: 3,517

Rep: Reputation: 58
Edit all your vfat containing lines as follows:

Code:
/dev/hdaX /mnt/Y vfat defaults,umask=000 0 0
 
Old 12-02-2004, 10:58 AM   #13
kadhan
Member
 
Registered: Dec 2004
Posts: 40

Rep: Reputation: 15
abisko00'
thank u.
 
Old 12-02-2004, 07:01 PM   #14
craigers
LQ Newbie
 
Registered: Jun 2004
Location: Wisconsin
Distribution: Mandrake Linux 10
Posts: 20

Original Poster
Rep: Reputation: 0
ok, when i first installed linux i had write permission to my windows ntfs drive but i had to take the windows drive out (forgot why) but i turned it on without that drive in and it did an auto config thing at the startup and everything got screwed up. i put the drive back in and had to go edit fstab so it would auto mount the drive again but now i cannot get write permission
running mandrake linux 10.0 Official
 
Old 12-03-2004, 06:00 AM   #15
binumvk
LQ Newbie
 
Registered: Mar 2004
Location: India
Posts: 24

Rep: Reputation: 15
haI IAM TALKING ABOUT REDHAT LINUX
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab not edit-able? lefty.crupps MEPIS 1 06-06-2005 05:36 PM
How do I edit /etc/fstab? linusownsme Linux - Software 9 03-05-2005 11:30 AM
Help me edit my fstab Slovak Slackware 3 11-26-2004 10:12 AM
edit fstab - what i ve to do ? thinkdifferent Linux - Newbie 4 12-23-2003 04:20 PM
edit fstab LinuxOG Linux - Distributions 2 09-01-2003 10:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration