LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   FreeNX: "Server not installed or NX access disabled" (https://www.linuxquestions.org/questions/linux-software-2/freenx-server-not-installed-or-nx-access-disabled-473639/)

cellist 08-14-2006 12:45 AM

FreeNX: "Server not installed or NX access disabled"
 
I realize I'm not the only one having this problem, but I'm hoping that some of you brilliant people out there will be able to help me with this one.

I'm running Kubuntu, and I've installed FreeNX and all required packages (running sudo apt-get install freenx nxclient libxcomp1 libxcompext1 nxagent nxdesktop nxlibs nxproxy nxviewer) from Seveas repo. I followed the instructions for setup as described here.
I'm trying to connect to my server using WindowsXP. The problem? I had a previous version of NXClient for Windows that I uninstalled at some point, and then reinstalled. When I installed the new version, it kept the old keys, etc. Now, I've configured the nxserver to use nomachine's keys, but all I ever get when I try to connect is "Server not installed or NX access disabled". I can SSH using PUtty, no problem, so it's clearly not a firewall problem. I then tried creating my own keys and adding them to the client following instructions I found here.

Now, I've tried so many things from different people that I think I have a horrible ssh key mess going on. I keep seeing references to checking the ssh log but I can't for the life of me find it. /var/log/auth.log has no references of ssh or nx, and there is nothing else in /var/log that has references to ssh. /var/log/nxserver.log is completely empty. My ssh debug level is currently set to 3, though it was set to INFO, and I tried DEBUG but that didn't seem to do anything.

So what do I do? I realize there are like five questions in this one post, so an answer to any one of them would be a godsend at this point. Thanks!

cellist 08-14-2006 01:11 AM

As an update: it turns out the nx account was locked, so I unlocked it with passwd -u nx, but I still can't log in. Tried setting up the default nomachines keys again, and nothing. Zip. Very frustrating.

cellist 08-14-2006 01:28 PM

Ok, so it turns out that OpenSSH wasn't running at all. LSH was, so all my careful editing of the config file didn't amount to much. I fixed that problem, and it says Authentication Completed, but the connection is getting dropped for some reason before the desktop window even opens.

Here's the relevant output (the SSH log is available, but it's very very long. I can post if needed):

NX> 148 Server capacity: not reached for user: [omitted]
NX> 105 startsession --link="lan" --backingstore="1" --nodelay="1" --cache="8M" --images="32M" --media="0" --session="Toshiba" --type="unix-kde" --cookie="******" --geometry="fullscreen" --kbtype="pc102/en_US" --screeninfo="1024x738x32+render"

NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)
NX> 700 Session id: toshiba-laptop-1000-4A6D10B184B6F44E87F3F8BAEED03E0D
NX> 705 Session display: 1000
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: ef785e0f1cee78920d3084e6c91bc690
NX> 702 Proxy IP: 192.168.132.103
NX> 706 Agent cookie: 65deafcf3c1ad1751415736c4cc11f76
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 0
NX> 105 /usr/lib/nx/nxserver: line 880: 24276 Terminated ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )
NX> 504 Session startup failed.
NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1
NX> 1001 Bye.
Killed by signal 15.

I don't understand what "option 1" is that it's complaining about, but whatever it is, it's crashing the connection.

Any help would be much appreciated!


All times are GMT -5. The time now is 03:22 PM.