LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-21-2007, 09:39 AM   #1
MegaSvensk
Member
 
Registered: Sep 2007
Posts: 43

Rep: Reputation: 15
FreeNX problem. nxagent fails to start


Hi,

I'm trying to get FreeNX working on my Ubuntu 7.10 so that I can access my desktop and files from work and other places. I did try VNC but it lacked a vital feature, namely audio.

I can't seem to get the FreeNX working though. When I attempt to connect (with NX client on Windows), I am connected and I pass the Authentication but then I get a "Session startup failed" error.

This is the log file:
Code:
NX> 203 NXSSH running with pid: 3968

NX> 285 Enabling check on switch command

NX> 285 Enabling skip of SSH config files

NX> 285 Setting the preferred NX options

NX> 200 Connected to address: 192.168.1.51 on port: *****

NX> 202 Authenticating user: nx

NX> 208 Using auth method: publickey

HELLO NXSERVER - Version 1.4.0-45-SVN OS (GPL)

NX> 105 hello NXCLIENT - Version 1.4.0

NX> 134 Accepted protocol: 1.4.0

NX> 105 SET SHELL_MODE SHELL

NX> 105 SET AUTH_MODE PASSWORD

NX> 105 login

NX> 101 User: vandelay

NX> 102 Password: 

NX> 103 Welcome to: vandelay-desktop user: vandelay

NX> 105 listsession --user="vandelay" --status="suspended,running" --geometry="1152x864x32+render+fullscreen" --type="unix-gnome"

NX> 127 Sessions list of user 'vandelay' for reconnect:



Display Type             Session ID                       Options  Depth Screen         Status      Session Name

------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------





NX> 148 Server capacity: not reached for user: vandelay

NX> 105 startsession  --link="lan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --samba="1" --media="1" --mediahelper="esd" --session="testing" --type="unix-gnome" --cookie="******" --geometry="fullscreen" --kbtype="pc102/se" --screeninfo="1152x864x32+render+fullscreen" 



NX> 1000 NXNODE - Version 1.4.0-45-SVN OS (GPL)

NX> 700 Session id: vandelay-desktop-1000-27029F78C5E4F767D63D3C1C8C720928

NX> 705 Session display: 1000

NX> 703 Session type: unix-gnome

NX> 701 Proxy cookie: a2d4ad3e3d92389e6537000b474ce36b

NX> 702 Proxy IP: 127.0.0.1

NX> 706 Agent cookie: a5406737c564723ad4ef302796bdbea0

NX> 704 Session cache: unix-gnome

NX> 707 SSL tunneling: 1

NX> 105 /usr/lib/nx/nxserver: line 880: 22194 Avslutad                ( sleep $AGENT_STARTUP_TIMEOUT; exit 1 )

NX> 504 Session startup failed.

NX> 1004 Error: nxagent failed to start with: Unrecognized option: 1

NX> 1001 Bye.

NX> 280 Exiting on signal: 15
I am guessing I have to change that unrecognized option but I have no idea where and to what.

Does anyone know how to get this working?

Thanks.

Last edited by MegaSvensk; 10-21-2007 at 09:53 AM.
 
Old 10-21-2007, 10:30 AM   #2
MegaSvensk
Member
 
Registered: Sep 2007
Posts: 43

Original Poster
Rep: Reputation: 15
I found this after searching on Google some more:
Quote:
Thorsten Sandfuchs found some issues concerning backingstore. Problem arouse as you try to connect to a 0.5.0 installation with no 2.0.0 backend support and a 2.0.0-client. As Nomachine changed the behaviour of the backingstore-option. In 1.5.0-clients the client sends "always, when_requested" et all and freenx just passed this string to the nxagent-call. The new client now sends "backingstore=1" and the 1.5.0-nxagent issues a warning and an error with "no argument requiered for -bs" or with "Error: NX Agent exited with exit status 1.". You can read all his message here: Backingstore or 2.0.0-client and 1.5.0 backend and freenx-0.5

Look at nxnode and in function 'node_start_agent()' after this line

[ -n "$backingstore" ] && B="-bs $backingstore"

add this lines:

# backingstore = { "when_requested", "always", ... }
[ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" != "1" -a "$backingstore" != "1" ] && B="-bs $backingstore"
# backingstore = 1 (new nxclient 2.0.0 doesn't send any strings in the option-string for backingstore anymore)
[ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" != "1" -a "$backingstore" = "1" ] && B="+bs"
# backingstore = 1 and 2.0.0-Backend EXPERIMENTAL
[ -n "$backingstore" -a "$ENABLE_2_0_0_BACKEND" = "1" ] && B="-bs $backingstore"

This works using nxclient version 2.0.0-98.

--Predseda3D 15:12 Aug 2, 2006 (BST)
This seems to be very similar to my problem, but I can't find the nxnode file that you're supposed to edit the lines into. I found node.conf, but that wasn't it because it didn't have the line I was supposed to look for.
 
Old 10-21-2007, 10:57 AM   #3
MegaSvensk
Member
 
Registered: Sep 2007
Posts: 43

Original Poster
Rep: Reputation: 15
Okay, I found the file and I added the lines but now it stops on a different error

Code:
Info: Display running with pid '2764' and handler '0x50188'.



NXPROXY - Version 3.0.0



Copyright (C) 2001, 2007 NoMachine.

See http://www.nomachine.com/ for more information.



Info: Proxy running in client mode with pid '832'.

Session: Starting session at 'Sun Oct 21 16:50:06 2007'.

Warning: Connected to remote version 1.5.0 with local version 3.0.0.

Info: Connection with remote proxy completed.

Info: Using LAN link parameters 1536/24/1/0.

Info: Using pack method '16m-jpeg-9' with session 'unix-gnome'.

Info: Not using NX delta compression.

Info: Not using ZLIB data compression.

Info: Not using ZLIB stream compression.

Info: Not using a persistent cache.

Info: Forwarding X11 connections to display ':0'.

Info: Forwarding SMB connections to port '139'.

Info: Forwarding multimedia connections to port '6000'.

Session: Session started at 'Sun Oct 21 16:50:06 2007'.

Warning: Cookie mismatch in the X authentication data.

Session: Terminating session at 'Sun Oct 21 16:50:06 2007'.

Info: Your session was closed before reaching a usable state.

Info: This can be due to the local X server refusing access to the client.

Info: Please check authorization provided by the remote X application.

Session: Session terminated at 'Sun Oct 21 16:50:06 2007'.
Can someone please help me with this? I don't know how to check the authorization.
 
Old 10-21-2007, 07:21 PM   #4
MegaSvensk
Member
 
Registered: Sep 2007
Posts: 43

Original Poster
Rep: Reputation: 15
Bump.

There must be someone who knows how to solve this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FreeNX Service wont start SpaceCrusader Linux - Software 3 08-05-2006 01:08 AM
freenx problem after authenticating rayyes Linux - Software 6 05-22-2006 11:01 PM
Freenx Authentication Problem linuxpyro Linux - Software 2 07-29-2005 08:21 AM
xinit fails just after Xserver start up, scsi-ide problem while mounting cdrw askjha Red Hat 0 06-03-2004 12:25 PM
xinit fails just after Xserver start up, scsi-ide problem while mounting cdrw askjha Red Hat 0 06-03-2004 10:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration