LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-07-2014, 01:52 AM   #1
whocares02
LQ Newbie
 
Registered: Jul 2014
Posts: 6

Rep: Reputation: Disabled
Unhappy Fontconfig-Error won't go away


Because my last threat doesn't work for some reason ("invalid post specified" when clicking on it) I post it again:

Hello,
I almost despair of bugfixing the following problem:

Code:
QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv failed for BOM: Bad file descriptor
QIconvCodec::convertToUnicode: using Latin-1 for conversion, iconv_open failed
QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv_open failed
Fontconfig error: Cannot load default config file
It's the output of a gui-application, showing nothing but boxes instead of characters in dialogues.

I googled around and people say it's fontconfig having trouble finding /etc/fonts/fonts.conf

I checked that but the file exists and is accessible.

Other people say it's pango not finding /etc/pango/pangorc or ~/.pangorc. Again I checked both: Both files are present and accessible.

In another threat somebody claims missing fonts were the problem causing the strange message. So I installed additional fonts to satisfy some entries in xorg.conf:

Code:
xorg.conf file :
Section “Files”
FontPath “/usr/share/fonts/X11/100dpi”
FontPath “/usr/share/fonts/X11/75dpi”
FontPath “/usr/share/fonts/default/ghostscript”
In my xorg.conf even more nonexistent font-paths are mentioned. I tried removing them but the entries reappear after reboot.

I installed
Code:
xfonts-tipa
xfonts-biznet-100dpi
xfonts-biznet-75dpi
xfontz-utils
xfonts-base
ghostscript-fonts
but the problem persists.

I built pango, fontconfig and freetype from source and reinstalled them - problem still present.

I reinstalled
fontconfig-config with it's dependencies: perl-base, ucf and debconfig, and installed libqtcore4_4.8.2+dfsg-11
- no change of problem.

After google can't give me anything new on the error-message (I really visited all the pages) I'm asking here now: Can please (!!!) somebody help me hunting down that error?

Edit:

Forgot mentioning that I also placed a script in /root/.kde/env/ to set two variables globally:

Code:
export FONTCONFIG_PATH=/etc/fonts
export PANGO_RC_FILE=/etc/pango/pangorc
Also, I found this threat reading

Quote:
Sounds like fontconfig got miscompiled somehow. It seems most likely that
the FONTCONFIG_PATH didn't get defined correctly.

Check your Makefile in src and ensure that you have something like:

....
sysconfdir = /etc
...
CONFDIR = ${sysconfdir}/fonts
...
INCLUDES = $(FREETYPE_CFLAGS) $(EXPAT_CFLAGS) -DFONTCONFIG_PATH='"$(CONFDIR)"' -I$(top_srcdir) -I$(top_srcdir)/src

Then run 'strings' on fccfg.o and make sure /etc/fonts is present in the
object file.
It's a quiet old post (dated 2003). In present fontconfig-source I couldn't find the mentioned lines in the /src/Makefile. Also don't know what the last line means:

Quote:
Then run 'strings' on fccfg.o and make sure /etc/fonts is present in the
object file.
 
Old 07-08-2014, 11:58 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
In times past, occasionally an application would encounter an error condition on opening the app. The error condition could be kept in a file in the users home directory. All attempts to get the app started would fail until the error file was deleted.

I don't know if that is what is happening with pango, BUT, on examining mine, I see in the <itemData> section a reference to Error. So, pango could be keeping an error file somewhere which doesn't allow you to get past it to see if your reinstallations have done any good.

In a terminal, run locate pango.xml. If it exists it should be somewhere in your home directory. Delete it. Also delete ~/.pangorc. A new one of each will be written the next time you use pango.

The only other thing that I can think of that may contribute to the problem is the use of Latin-1, which is used for the following languages: Afrikaans, Basque, Catalan, Danish, Dutch,
English, Faeroese, Finnish, French, Galician, German, Icelandic, Irish, Italian,
Norwegian, Portuguese, Scottish, Spanish, and Swedish.

If the language you want to display is not one of those, you need to use a different font set.
Quote:
Also don't know what the last line means:

Quote: Then run 'strings' on fccfg.o and make sure /etc/fonts is present in the
object file.
fccfg.o is an object file (binary) which you can't read in a file viewer. The strings utility can give you a look inside the binary for strings of text.
example: in a terminal, run strings fccfg.o

Last edited by bigrigdriver; 07-08-2014 at 05:14 PM.
 
Old 07-10-2014, 08:43 AM   #3
whocares02
LQ Newbie
 
Registered: Jul 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thank you, I'll try to find an remove the mentioned files. Yes, the language I use is one of the latin-1-languages. What if /etc/fonts isn't present in the fccfg.o-file? I will check this of course. But when it's a binary is there a way to inject the path anyway? In case of a missing entry I don't know how and where to include. I'm on a different computer right now. I'll report back as soon as I checked your suggestions.
 
Old 07-10-2014, 04:06 PM   #4
whocares02
LQ Newbie
 
Registered: Jul 2014
Posts: 6

Original Poster
Rep: Reputation: Disabled
The command locate doesn't exist on my system. So I ran

Code:
find / -name "pango.xml"
and
Code:
find ~ -name "pango.xml"
But got no results. I also erased ~.pangorc but it didn't change anything. The file also wasn't re-created.

In the fontconfig-source-directory I found fccfg.o in the subfolder /src/.libs/

When running

Code:
strings fccfg.o
I get a huge list of strings. So I typed

Code:
strings fccfg.o | grep /etc/fonts
The output was:

Code:
/etc/fonts
I guess it means that the string was found in the file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fatal error: fontconfig/fontconfig.h: No such file or directory bogzab Slackware 3 11-07-2011 03:13 PM
fontconfig error xenes Debian 4 03-13-2007 03:45 AM
Fontconfig error umaru Slackware 8 08-04-2006 10:49 AM
Fontconfig error; can't start X Alien_Hominid Slackware 3 01-31-2006 11:48 AM
fontconfig (cvs version) won't compile... GuntherDW Linux - Software 2 08-04-2004 03:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration