-   Linux - Software (
-   -   fluxbox help (

lasalsademuerte 10-26-2003 10:34 PM

fluxbox help
I've installed fluxbox and I can run it fine if I set inittab to reunlevel 3, login and type xinit and then type fluxbox in the xterm. However I would like to have it added to the sessions menu at the login gui in redhat 9, I tried creating a fluxbox file containing exec /usr/local/bin/fluxbox in the /etc/X11/gdm/Sessions/ directory and this allowed me to select fluxbox in the sessions options but when fluxbox loaded I got a messege saying that I had been logged in for less than 10 second(that may not be exactly it but that was about what it said) and that it may be a result of a lack of disk space. However since I can load fluxbox from text this is obviously a bogus error message. Does anyone have any idea what I may be doing wrong. Also is there anyway that after I load fluxbox I can clse the xterm without exiting out of fluxbox? thanks for any help you can give me.

slakmagik 10-26-2003 11:24 PM

This isn't directed at you especially, in that lots of people do it - just a broadcast message:

This is not a fluxbox problem!

People would probably get better and faster help if they'd correctly identify the issue. Flux may be what prompts awareness of the problem, but you need 'gdm help'.

Now, I don't know anything about gdm or redhat - I clicked on your thread because it said 'fluxbox'. If you can execute from runlevel 3 like that, though, you should be able to create or modify an ~/.xinitrc whose *last* line is 'exec fluxbox' and then do 'startx'. That way flux will be controlling the session rather than the terminal emulator. Then you can close the term without closing the session.

xterm &
exec fluxbox

See if you have an xinitrc anywhere on the system you can copy and modify if you don't already have the dotfile in your home directory. And I hear there's a thing called 'switchdesk' on RH - some people seem to have trouble - for some people it works. I don't know. As far as adding to a graphical login prompt, though, I really don't know - completely forgotten those, though I did use one on my first install and had to disable one on Debian not long ago.

All times are GMT -5. The time now is 12:04 PM.