LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-08-2009, 06:48 AM   #1
hubabuba
Member
 
Registered: Jan 2002
Location: UK
Distribution: Slack 14.1
Posts: 193

Rep: Reputation: 30
Fluxbox 1.1.1 - Can't get a theme to work properly


Hi

I know this probably has been brought up several times, but I cannot find the reason why the theme I'm trying to use will not work properly on Slack 12.2, Fluxbox 1.1.1.

First of all, the theme background will not come up when Fluxbox starts.
Only using the command:

Quote:
fbsetbg ~/.fluxbox/styles/n3/pixmaps/vortex_bsd_013_technodream.jpg
... brings up the backgound, but only until Fluxbox is restarted again.

I have the .fluxbox/styles directory with the theme.cfg file. The file contans the following command:

Quote:
rootCommand: fbsetbg ~/.fluxbox/styles/n3/pixmaps/vortex_bsd_013_technodream.jpg
.. but does nothing

Secondly the rootmenu changes style, but not completely, i.e. it should be transparrent, but it is not and is too large.

Last edited by hubabuba; 03-08-2009 at 06:49 AM. Reason: missed word
 
Old 03-08-2009, 02:29 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 13,186
Blog Entries: 1

Rep: Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047Reputation: 2047
For your 1st prob:
Once you have set the background image using:
Quote:
fbsetbg -f ~/.fluxbox/styles/n3/pixmaps/vortex_bsd_013_technodream.jpg
then you should put:
Code:
session.screen0.rootCommand:    fbsetbg -l
in ~/.fluxbox/init
About your 2nd problem, I think it's related to the first. See if anything is OK after setting the background in the ./fluxbox/init file.

Last edited by bathory; 03-09-2009 at 01:00 AM.
 
Old 03-08-2009, 05:48 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,274

Rep: Reputation: 63
To make my theme's background work properly I did this:
1. leave session.screen0.rootCommand: blank
2. at the end of your theme config file include 2 lines:
background: center
background.pixmap: <path to file>

As for the transparency and menu size, look for session.screen0.toolbar.alpha and session.screen0.menu.alpha in ~/.fluxbox/init. The size is most likely caused by the font size. Mine is set in the theme file with menu.title.font: and menu.frame.font: and I use lucidasans-10 font
 
Old 03-09-2009, 09:23 AM   #4
hubabuba
Member
 
Registered: Jan 2002
Location: UK
Distribution: Slack 14.1
Posts: 193

Original Poster
Rep: Reputation: 30
Thanks for help.

I will make the changes later today.
 
Old 03-09-2009, 04:19 PM   #5
hubabuba
Member
 
Registered: Jan 2002
Location: UK
Distribution: Slack 14.1
Posts: 193

Original Poster
Rep: Reputation: 30
Great! Everything works now apart from the font size.

My theme.cfg file had the following lines:
Quote:
menu.title.font: -artwiz-snap-*-*-*-*-*-*-*-*-*
menu.frame.font: -artwiz-drift-*-*-*-*-*-*-*-*-*
I changed them to:
Quote:
menu.title.font: -artwiz-snap-10
menu.frame.font: -artwiz-drift-10
Font size hasn't changed.

Also, a question. Why did I have to change session.screen0.toolbar.alpha and session.screen0.menu.alpha in ~/.fluxbox/init to a lower setting (I set it to 110, as in the theme config file) to make the menus transparent, if theme.cfg file already had 110 setting? It seems to ignore theme.cfg file for some settings.
 
Old 03-26-2009, 02:40 PM   #6
ramram29
Member
 
Registered: Jul 2003
Location: Miami, Florida, USA
Distribution: Debian
Posts: 848
Blog Entries: 1

Rep: Reputation: 47
I had trouble with fluxbox 1.1 on my Debian Testing install. I updated my sources list to Debian Stable, deinstalled fluxbox then installed it and it worked. Debian Stable installs the fluxbox 1.0 which works fine without the stupid fbsetbg error. Try fluxbox 1.0 and not 1.1 (which is the development version).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mozilla browser does not open properly after changing theme MizzYellow SUSE / openSUSE 6 07-01-2006 01:23 PM
fluxbox theme boolim Slackware 2 03-18-2005 06:36 AM
Transparencies doesnt work properly Slackware 10.1 + fluxbox Nah Slackware 5 03-06-2005 07:19 PM
my new Fluxbox theme acid_kewpie General 12 07-20-2004 02:01 AM
fluxbox theme gabebster Linux - Software 7 08-17-2003 04:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration