LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2005, 11:50 AM   #1
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Rep: Reputation: 31
floppy and CD disk filenames cut off


I copied a file from my Windows computer to a floppy. When I load the floopy in Linux, this is how many of my filenames look: dock&s~1.doc

Is there a way to correct this? Or do I have to rename my files everytime.
 
Old 05-27-2005, 01:43 PM   #2
towlie
Member
 
Registered: Apr 2004
Location: U.S.
Distribution: slackware 10.0
Posts: 110

Rep: Reputation: 15
Look at the man page for mount. Find the section on loading
msdos floppies, and you should see some options allowing
longer file names.

Then use that option in your mount command or your
/etc/fstab, whichever you use.
 
Old 05-27-2005, 01:50 PM   #3
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by towlie
Look at the man page for mount. Find the section on loading
msdos floppies, and you should see some options allowing
longer file names.

Then use that option in your mount command or your
/etc/fstab, whichever you use.
Thank you for your reply. I don't understand what you mean though. I don't see anything on my main or man page about mount. And I'm a newbie. I don't know how to reconfig the programming in the fstab file.
 
Old 05-27-2005, 02:03 PM   #4
towlie
Member
 
Registered: Apr 2004
Location: U.S.
Distribution: slackware 10.0
Posts: 110

Rep: Reputation: 15
I know all this can be confusing, so let me know if you
need more explanation on something.

To see the man page for mount, go to a terminal. You probably
have an icon on your desktop or down in the tool bar that
looks like an msdos window.

Open it up and you can type commands like 'man mount'
or whatever you want. (btw, you may want to gradually
begin learning more about these basic commands, look
at man pages for the following when you get a chance:
ls
cd
pwd
mv
rm
rmdir
mkdir

The mount program is different on every system, so you'll
have to look at your man page to get the correct option.

Do you manually mount the floppy every time (if you don't
know what that is then you're not)?

If you do, add the correct option from the mount man page
to your command.

Otherwise, it's probably in your /etc/fstab file. I believe that
the mount and fstab man pages have info on how to modify
this file correctly so try to read fstab man page too.
 
Old 05-27-2005, 02:21 PM   #5
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
[QUOTE]Originally posted by towlie
Quote:
Open it up and you can type commands like 'man mount'
or whatever you want.
This is what I got after I typed in man count:
username@ubuntu:~$ man count
No manual entry for count


Quote:
Do you manually mount the floppy every time (if you don't
know what that is then you're not)?
When I click the icon for the floppy, it mounts automatically.

Quote:
Otherwise, it's probably in your /etc/fstab file. I believe that
the mount and fstab man pages have info on how to modify
this file correctly so try to read fstab man page too. [/B]
I really have no idea on what you're talking about. I'm a complete newbie to this. Please speak in simple terms. Couldn't I just right click something to get the floppy to read as a dos floppy?
 
Old 05-27-2005, 02:36 PM   #6
towlie
Member
 
Registered: Apr 2004
Location: U.S.
Distribution: slackware 10.0
Posts: 110

Rep: Reputation: 15
Quote:
This is what I got after I typed in man count:
username@ubuntu:~$ man count
No manual entry for count
You did type 'man mount' right? Not 'man count'.

If you right click the floppy icon and go to properties, what
kind of options does it give you?
 
Old 05-27-2005, 02:46 PM   #7
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by towlie
You did type 'man mount' right? Not 'man count'.

If you right click the floppy icon and go to properties, what
kind of options does it give you?
Oh. My mistake. man mount worked. It brought up a manual. And nothing pertaining to reading DOS floppies comes up when I right click the floppy icon.
 
Old 05-27-2005, 02:52 PM   #8
towlie
Member
 
Registered: Apr 2004
Location: U.S.
Distribution: slackware 10.0
Posts: 110

Rep: Reputation: 15
Probably what you need to change is in the file /etc/fstab.
If you change it, make a copy of it first so you can back
it up if something goes wrong.

I think like the 4th or 5th column is the option column,
the options in that column are listed and separated by
commas with no spaces.

Just read the mount and fstab man pages until you find
an option you think will let you get longer filenames.

Then open a text editor (you can probably find one from
your main menu, you'll have to open it as root) and change
the /etc/fstab file.

After you reboot, the changes you made will take effect.

I don't know what the exact change would be though, so
you can either back up /etc/fstab, and try some stuff out,
or, to be safer, you can wait and see if anyone else here
can tell you exactly what change to make, your call.
 
Old 05-27-2005, 03:02 PM   #9
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
I'm so lucky I know something about computers. Linux is NOT ready for novice / average users. Not yet.


Here is what my fstab file looks like right now:

Quote:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda8 /boot ext3 defaults 0 2
/dev/hda7 /home ext3 defaults 0 2
/dev/hda9 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
The floppy settings look accurate. Auto seems like it would be the best option. Maybe I'm wrong. If I put ntfs in the place of auto, do you think that'll do the trick?

Thanks again for your time and patience.
 
Old 05-27-2005, 03:17 PM   #10
towlie
Member
 
Registered: Apr 2004
Location: U.S.
Distribution: slackware 10.0
Posts: 110

Rep: Reputation: 15
Don't think ntfs would work, cuz dos floppies usually
aren't formatted with ntfs.

I think msdos is what you should put in 3rd column
in place of auto on your /dev/fd0 line.

Then to get long filenames you would have to put an option
in the 4th column.

Looked on a bsd manpage, the option was called 'longnames'.
Maybe the option on your system is similar?

On my man page for mount, if you go down far enough, you'll
see a section about file-system specific options. If your man page
has the same section, I think that's where you'd find the option,
probably in the msdos sub-section.
 
Old 05-27-2005, 03:23 PM   #11
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
Quote:
Originally posted by Cinematography
I'm so lucky I know something about computers. Linux is NOT ready for novice / average users. Not yet.
Actually, it is ready. It is selling quite well in Sprawl*Mart, actually.

It depends on what distribution you choose. Distributions like Linspire, Mandrake/Mandriva, and Suse are extremely user-friendly. Distributions such as Slackware are less so.

Quote:
Here is what my fstab file looks like right now:

Regarding:

Code:
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
It is probably mounting the floppy as "msdos" which is FAT12/16, limiting you to 8.3 filenames. You should mount the CDs as "vfat" and you can do it either via a shell prompt (man mount, as others have indicated) or you can change the line in fstab to the following:

Code:
/dev/fd0 /media/floppy0 vfat rw,user,noauto 0 0
Of course, now if you put an ext, hpfs, ntfs, hfs, or any format other than fat/fat32, it won't mount the floppy automagically, but you will get LFN functionality on Windows-formatted floppies.

Regarding CDs: You need to burn CDs with the Joliet extensions. How this is done depends on the program you are using to create CDs; with k3b there is a checkbox for enabling Joliet filenames, and to extend filename limits up to 103 characters.

Oh and just a tip: there are many, many threads covering this topic already. If you had taken the time to search you'd have found the solution around 12:50 today.
 
Old 05-27-2005, 03:39 PM   #12
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
This line did it:
/dev/fd0 /media/floppy0 vfat rw,user,noauto 0 0

Thanks a lot towlie and KimVette for your help! I'm one step closer to having a perfect running Linux OS.
 
Old 05-27-2005, 03:48 PM   #13
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
Here is a tutorial I wrote based on your responses for this problem:

Quote:
Log in as root user by entering the following into a terminal:
su root

Edit your fstab file by entering this next:
gedit /etc/fstab

Replace this line:
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

With this line:
/dev/fd0 /media/floppy0 vfat rw,user,noauto 0 0

Save and reboot

Last edited by Cinematography; 05-27-2005 at 03:49 PM.
 
Old 05-27-2005, 03:56 PM   #14
Cinematography
Member
 
Registered: Apr 2005
Location: Chicago, IL
Distribution: openSUSE 13.1
Posts: 357

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by KimVette
Oh and just a tip: there are many, many threads covering this topic already. If you had taken the time to search you'd have found the solution around 12:50 today.
You can't do a search when you don't know what you're searching for. I'm not familiar with all of the terms, and I had NO idea fstab was where these settings were.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
effect of power cut on hard disk and motherboard kushalshah Linux - Hardware 6 06-30-2004 03:50 PM
Using a floppy disk to load a USB disk. joeyjwc Linux - General 2 03-21-2004 06:05 PM
msdos formatted floppy showing 8.3 filenames sridharinfinity Slackware 1 03-04-2004 09:25 AM
Floppy disk fail to boot when install suse 8 with boot from floppy ffang Linux - Newbie 0 08-18-2003 08:44 PM
'cat' not allowing absolute filenames when piped to 'cut' d3funct Programming 6 12-06-2002 02:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration