-   Linux - Software (
-   -   Flash pages working in chrome but not in firefox (

StefanP 08-21-2011 02:47 PM

Flash pages working in chrome but not in firefox
I have downloaded the latest flashplayer and followed the instructions to install (copied to /usr/lib/mozilla/plugins, and also all other files in corresponding locations). When I access pages with flash in Google Chrome it works but same pages don't work in Firefox. When I check adobe site it says firefox has correctly installed flash but when I check the ad-ons it says it's outdated. What can be done?

jdkaye 08-22-2011 08:10 AM

Maybe if you told us what pages don't work (provide the url's) and what version of the flash plugin you're using then someone might find a solution for you. Or would you rather we guessed. ;)

StefanP 08-22-2011 10:22 AM

sorry, latest version of flashplayer 10, firefox 6 (though 4&5 had same problem), and all YouTube pages I tried give error, also games in Facebook like Tetris.

jdkaye 08-22-2011 11:49 AM

When you click on the Tools menu in FFx and then on the Add-ons item and then on Plugins, do you see Shockwave Flash and then the version number on the line below?

netnix99 08-22-2011 11:54 AM

...just a thought... are you running a 64-bit OS??

If so, you need the 64-bit, and it goes in /usr/lib64/mozilla/plugins

Here is the link for the 64-bit flash

StefanP 08-22-2011 07:58 PM

Small improvement
Thank you for still trying to help me... I do not run 64 bit..

I did check right now the version and to my surprise I found (yesterday was not like that) that after installing the latest Flash yesterday I actually had 2 Shockwave Flash versions enabled:

Shockwave Flash 10.1 r999 Gnash 0.8.8 the GNU SWF Player
Shockwave Flash 10.3 r183

I disabled the 10.1 r999 Gnash... and now YouTube videos work but still Facebook games don't load and also if I go google maps it would not display images from street level (still an improvement as YouTube works now :)

jdkaye 08-23-2011 01:12 AM

Sorry Stefan. I don't use Facebook and know nothing about it so I can't help you there. FYI, there is a later version of Shockwave Flash 11.0 d1 (I'm using a 64bit version) but I have no idea if that will help you or not. You could always try it.

rokytnji 08-23-2011 01:58 AM

I just installed Shockwave Flash 11.0 d1 (32 bit) in my AntiX 11 install. I guess it depends on your distro where goes.

In my /usr/lib/mozilla/plugins folder there is a symlink that points to /usr/lib/flashplugin-nonfree folder where actually sits where Iceape browser and Opera Browser can pick it up. But like I said. Depends on Distro for file location sometimes.

Edit. Noticed your Debian 4 in profile. Mine is


$ lsb_release -a
No LSB modules are available.
Distributor ID:        Debian
Description:        Debian GNU/Linux testing (wheezy)
Release:        testing
Codename:        wheezy


$ locate

All times are GMT -5. The time now is 10:55 AM.