-   Linux - Software (
-   -   Flash audio frozen in a loop in Firefox on Debian after some hours of usage. (

tospo 08-10-2010 04:08 AM

Flash audio frozen in a loop in Firefox on Debian after some hours of usage.
my system:
Debian v.5.0.5,
architecture: i686,
Firefox 3.6.3 (but had the same problem with older versions of Firefox),
Flash: Shockwave Flash 10.0 r32

After a fresh X start, Flash works without any problems for a day or so but then at some point the audio starts to freeze in a loop (sounds like an old record with a scratch) and the video also freezes up. This happens while listening to, but the same problem affects other flash videos on other sites but apparently only if they have an audio track, so I think it is mostly an audio buffer problem.
Restarting Firefox doesn't seem to help but when I log out and start a new session (rebooting is not necessary) it is fine again.
Does anybody else have that problem? I couldn't find anything so far and I don't have root access to this machine, so I'm a bit restricted.

Does anybody know which files flash writes to for buffering stuff? Maybe I can just delete a file that has been somehow corrupted instead of restarting? It's quite annoying if you have lots of applications running.

Thanks for your help!

craigevil 08-10-2010 05:40 AM

That is a really old version of Flash. Are you using Firefox if so how did you install it?

Update Flash and Firefox.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20100722 Firefox/3.6.8
Shockwave Flash

Filename /usr/lib/flashplayer-mozilla/
Plugin Version:
Plugin Description: Shockwave Flash 10.1 r53


Package flashplugin-nonfree

* lenny-backports (web): Adobe Flash Player - browser plugin [contrib]
1:2.8.1~bpo50+1 [backports]: amd64 i386
* squeeze (testing) (web): Adobe Flash Player - browser plugin [contrib]
1:2.8.1: amd64 i386
* sid (unstable) (web): Adobe Flash Player - browser plugin [contrib]
1:2.8.1: amd64 i386

How to update the Adobe Flash Player :

/usr/sbin/update-flashplugin-nonfree --install

Or install the version from the repo
$ apt-cache policy flashplayer-mozilla
Installed: 1:
Candidate: 1:
Version table:
*** 1: 0
500 unstable/non-free Packages
100 /var/lib/dpkg/status

tospo 08-11-2010 03:02 AM

Thanks craigevil.

Well, to be fair, my system is not THAT outdated - I'm using version 10.0 of Flash and 3.6.3 of Firefox, current versions are 10.1 and 3.6.8, respectively, so I think it's still reasonable to expect those to work.
Still, upgrading might help of course and it would be the first thing I would do on my own machine but I have no sudo rights on this one, so it's not an option.
I'm sure there must be a file somewhere which Flash tries to buffer audio streams to and that gets corrupted for some reason. I just don't know where to look for it.
Thanks anyway!

DrDwayne 09-23-2010 06:37 PM

I am having the same problem. It tells me I need to update my flash player.

I tried both of your update and install,but both failed.


DAR:/home/dwayne# /usr/sbin/update-flashplugin-nonfree --install
bash: /usr/sbin/update-flashplugin-nonfree: No such file or directory

DAR:/home/dwayne# apt-cache policy flashplayer-mozilla
W: Unable to locate package flashplayer-mozilla
I have downloaded it into my homedirectory/Downloads/


DAR:/home/dwayne/Downloads# dir
I would like to install both of these. The firefox I *can* run if I manually go to the directory and run it. But I would like to have it installed for all users as well as the flashplayer.

I *am* a newbe

Thank you in advance for your help.


modonnell 11-11-2010 01:19 PM

We've been seeing that looping-Flash-audio problem for a long time - at least a year and probably longer, despite several upgrades of kernel, Firefox and Flash. Description: after Firefox and the Flash plugin have been running for any length of time seems that audio is suddenly b0rken such it seems to consist solely of repeated renderings of the same brief segments - it can be rather surreal. Other audio apps do not suffer when executed at this time and restarting Firefox always restores the desired behavior, which implies that it's a problem with Flash, or maybe Firefox. I have not tried restarting just the Flash plugin but it sounds like this is the same problem everybody else has described.

############## distro/kernel version
Debian 2.6.30-2-686 #1 SMP Fri Dec 4 00:53:20 UTC 2009 i686 GNU/Linux

############## browser version
Firefox version 3.6.12

############## Flash version
Adobe Flash version

############## lsmod | fgrep -i -e intel -e hd -e snd -e aud -e sound
snd_hda_codec_idt 49836 1
snd_hda_intel 22192 4
snd_hda_codec 63596 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 6120 1 snd_hda_codec
snd_pcm 62416 3 snd_hda_intel,snd_hda_codec
snd_seq 42304 1
snd_timer 17460 3 snd_pcm,snd_seq
snd_seq_device 6136 1 snd_seq
snd 49028 15 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore 6184 1 snd
snd_page_alloc 8116 2 snd_hda_intel,snd_pcm

############## Debian ALSA pkgs installed:

alsa-base 1.0.23+dfsg-2
alsa-utils 1.0.23-3
gstreamer0.10-alsa 0.10.30-1
libasound2 1.0.23-2.1
libasound2-dev 1.0.23-2.1
libasound2-doc 1.0.23-2.1
libasound2-plugins 1.0.23-1+b1
libsdl1.2debian-alsa 1.2.14-6.1
linux-sound-base 1.0.23+dfsg-2
xmms2-plugin-alsa 0.7DrNo+dfsg-2

############## lspci info

00:10.1 0403: 10de:026c Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2) Kernel driver in use: HDA Intel

tospo 11-12-2010 05:30 AM

modonnell, yes that is exactly the problem I have. So far, I only ever had it when listening to streams but that may be simply because it is the only time I have a continous audio stream on for a long period of time. When I then just close and restart firefox, I usually get the same problem (or a connection problem is reported). But when I press the stop button and then re-start firefox, it usually (but not always) works. Weird...

All times are GMT -5. The time now is 11:44 PM.