-   Linux - Software (
-   -   Flash animations w/o sound! (

Tokaia 03-15-2005 07:45 AM

Flash animations w/o sound!
I play Neopets alot, and really enjoy some of the Flash games. However, I have just recently (within the last week) switched to Mandrake Linux 10.1 from Windows XP, and I'm still terribly unfamiliar with it. But it was for the best. Windows' service and security sucked anyway.

I installed the latest version of Macromedia Flash Player so I could play my beloved games. But there's no sound! I have no idea what the problem could be, and I wonder if anyone could help me out?


tolstoy 03-15-2005 08:04 AM

I have encountered the same exact problem on Slack 10 and FireFox. From the little bit of research I've done, the problem seems to be with ALSA and OSS emulation. I could be wrong about this, but I found a thread concerning this posted somehwere by the guy who worked on the code for the flash linux implementation at macromedia.

I have noticed, however, that I can get sound with Flash when I run FireFox as root. Try this (run your game as root) and see if you get sound. I don't know what is going on, and was hopeing someone could shed light on this oddity for me, but this seems to be the case for me.

Tokaia 03-16-2005 07:44 AM

How do I run FireFox as root?

jbcolmena 03-16-2005 08:32 AM

i.- open the console,
ii.- type: su root
iii.- type your password
iv.- type: firefox & (not sure wheter the f should be upper case... not in my box, so I cannot check it out)
if it doesn´t work, you have to find where the firefox executable is. You may do this using the right mouse butom -not sure about the spelling on that one- on the firefox icon. So you get to where the file is, and type: ./-executable- &.
where -executable- is the name of the file, wich should be firefox -again, not in my box, so cannot check it out. sorry- but anyhow you can see it when you right-click on the icon.

the "&" tells your system that you may keep using the console, and I believe even close it, and the program should keep running.

hope that helped a bit...

the basic idea is: you switch user to root (su root), then call the program (but you need to know where it is and how it's named) and that's it.

Tokaia 03-18-2005 02:45 PM

:cry: That didn't work.

bullium 03-18-2005 03:14 PM

while logged in as root open a terminal and type

# find / -name firefox -print
this should tell you were firefox is located.

Tokaia 03-18-2005 03:16 PM

I already know where it is, and tried running it as root. I did not get my sound back.

bullium 03-18-2005 03:37 PM

Just checking, but your system sound is working right? I mean outside of firefox your sound works?

Tokaia 03-18-2005 05:53 PM

Well, sort of... :( I can play music. Hovever, I can no longer hear my system sounds, even after I told it to play system sounds in the 'configure your desktop' option. Why they were de-selected in the first place is beyond me. I did try to use different drivers for my sound card, none of which worked. Upon switching back to the first one, system sounds no longer played, and when I booted up this morning, it said my audio drivers had failed to initialize! :cry: But that got fixed with a reboot.

I've tried downloading an older version of Flash. I've even tried re-installing the new version. I've tried configuring Mozilla Firefox, and I've tried playing with my sound card drivers. I'm becoming really upset! Could my sound card be incompatible? Its an AC'97, I think. Not sure what company made it. Linux would be just perfect if only I had my system sounds and flash sounds!

I'm also having a problem with my directional keys on my keyboard. Some of the flash games on Neopets require their use, but they don't work in those games! It has me wondering if this mess is Flash-related, and that the non-working keys are part of it.

Its just one thing after another!:mad:

marioitalo 03-18-2005 06:07 PM

Tokaia, try this for System notifications:

liquidtenmilion 03-19-2005 12:49 PM

open up konsole

then type in


then the root password

then type chmod 666 /dev/dsp*

then go into the configure your desktop link in the menu, and then sound options or something(towards teh bottom).

then click on sound server, and tell it to supsend itself after 2 seconds.

then try flash.

Tokaia 03-19-2005 03:13 PM

Well, it worked for a little bit. :( But then I tried to play music in amaroK, but it wouldn't play. So I tried to play music in Kaffeine. That worked, but then I lost my flash sound again. I re-did the little trick above, but it didn't work. This is getting irritating!!!:cry:

marioitalo 03-19-2005 10:09 PM

I solved this here executing firefox with "aoss" before it, like this:
aoss firefox
Hope it help. By.

liquidtenmilion 03-20-2005 09:55 AM

are you using alsa?

if so do this.

create a file


and as it's contents add

pcm.card0 {

type hw

card 0

mmap_emulation true


pcm.!output {
type dmix
ipc_key 1234
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
bindings {
0 0
1 1

# DSNOOP output device
pcm.!input {
type dsnoop
ipc_key 4321
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
rate 48000

# ASYM duplex device
pcm.!duplex {
type asym
playback.pcm "output"
capture.pcm "input"

# Make the duplex device default
pcm.!default {
type plug
slave.pcm "duplex"

# OSS Compability

pcm.!dsp0 {
type plug
slave.pcm "duplex"

ctl.!mixer0 {
type hw
card 0

and then set everything to use alsa. It will allow you to play more than one soudn at once.

Also, go back to that section in the configure your desktop link, and then sound system, and make sure that it is set to Advanced Linux Sound Architecture instead of autodetect.

If you are not using alsa, then switch to alsa.

go into the configure your computer link, and then type in your password, then it's somewhere in sound or hardware or something(haven't used mandrake in a while) and then configure your sound, and when it asks, tell it to use a driver that starts with snd

Tokaia 03-20-2005 10:54 AM

Okay, once I quit out of Kaffeine, my flash sound came back. Hopefully it stays. Hovever, I now have a problem with Fash's video. It keeps sticking every few seconds, and its extremely irritating.

No, i'm not using Alsa. I don't even know what it is. :( How do I do all that stuff you described?

All times are GMT -5. The time now is 01:50 PM.