LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-04-2008, 03:08 AM   #1
jpmaxyusuf
Member
 
Registered: Jul 2008
Posts: 47

Rep: Reputation: 15
Firewall error in RHEL 5.0


Sir,

After firewall, SQUID 2.6 configured the following error occur when restarting the SQUID.

Stopping squid: 2008/10/04 12:26:48| parseConfigFile: line 2185 unrecognized: 'httpd_accel_port 80'
2008/10/04 12:26:48| parseConfigFile: line 2186 unrecognized: 'httpd_accel_host virtual'
2008/10/04 12:26:48| parseConfigFile: line 2216 unrecognized: 'httpd_accel_with_proxy on'
2008/10/04 12:26:48| parseConfigFile: line 2237 unrecognized: 'httpd_accel_uses_host_header on'


In two eathernet card the LAN which means 192.168.2.1 ip not pinging with

the windows clients. i need to know what is the problem.


Can SQUID worke with Firewall..... I Use the following command to Redirect the internet connection to PROXY port 3128.

iptables -t nat -A PREEROUTING -i eth0 -p tcp --dport 80 -j DNAT --to 192.168.2.1:3128

iptables -t nat -A PREROUTING -i eth1 -p tcp --dport 80 -j REDIRECT --to-port 3128

when i put the Default gateway of the windows client is the ip of the Linux LAN ip why.

And how i check the client system working with Firewall.....

Thanks and Regards

S. A. Yusuf Sithik.

Last edited by jpmaxyusuf; 10-04-2008 at 03:10 AM. Reason: spell mistake
 
Old 10-04-2008, 03:49 AM   #2
WorldIsNotFair
Member
 
Registered: Jun 2008
Location: Jakarta
Distribution: CentOS 5
Posts: 89

Rep: Reputation: 17
Squid 2.6 doesn't apply those parameter anymore for configuring transparent proxy.

use http_port 3128 transparent
always_direct allow all

for redirecting using iptables, please describe your network setup.
 
Old 10-07-2008, 12:12 AM   #3
jpmaxyusuf
Member
 
Registered: Jul 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Network setup for redirect.

Hai,

Thanks for your kind response. Here i enclosed the Network Details of our company.

Windows clients : 40 No

Ip address ranges : 192.168.0.101 to 192.168.0.145

Subnet : 255.255.255.0

RHEL 5.0 Configuration

Ip address for eth0 202.71.145.114

Subnet : 255.255.255.248

Internet Gateway : 202.71.145.113

gateway Router ip : 192.168.0.1

Ip address for eth1 192.168.0.37

Subnet : 255.255.255.0

Gateway : 192.168.0.1.
 
Old 10-07-2008, 01:56 AM   #4
WorldIsNotFair
Member
 
Registered: Jun 2008
Location: Jakarta
Distribution: CentOS 5
Posts: 89

Rep: Reputation: 17
so, eth0 is connected directly to your internet provider ?

- what for you put router (192.168.0.1) ?
you simply can route it from RHEL machine ...

so, what is the default gateway for your windows machine and RHEL ?
 
Old 10-07-2008, 02:18 AM   #5
jpmaxyusuf
Member
 
Registered: Jul 2008
Posts: 47

Original Poster
Rep: Reputation: 15
Default gateway

Default gateway for windows machines is 192.168.0.1(Router IP)

Default gateway for RHEL Machine is eth0 : 202.71.145.113

eth1 : 192.168.0.1. I think some mistake i made but i dont know what i made.........

Thanks and Regards

S. A. Yusuf Sithik.
 
Old 10-07-2008, 09:00 AM   #6
WorldIsNotFair
Member
 
Registered: Jun 2008
Location: Jakarta
Distribution: CentOS 5
Posts: 89

Rep: Reputation: 17
ok .. so now we focused on RHEL Setting :

- eth0 = 202.71.145.114 (to internet)

- eth1 = 192.168.0.1 (to LAN)

- Gateway = 202.71.145.113

This is the step you can try and follow:

1. make sure you allowing ip forwarding
/proc/sys/net/ipv4/ip_forward -- set it value to 1

2. after that, windows machine should be able to ping
RHEL gw (202.71.145.113)

3. u don't mention ur dns nameserver ... u should set it, before
we try to browse any website.

4. from this step, u should able to connect internet from your
windows client without proxy.

5. for redirecting, use this on RHEL machine :
iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT
--to-ports 3128

6. restart your iptables & test it from windows client.

7. for monitoring squid you can tail it by :
tail -f /var/log/squid/access.log

note that there should be no error in squid before u configure iptables.

hope works friend.


Quote:
Originally Posted by jpmaxyusuf View Post
Default gateway for windows machines is 192.168.0.1(Router IP)

Default gateway for RHEL Machine is eth0 : 202.71.145.113

eth1 : 192.168.0.1. I think some mistake i made but i dont know what i made.........

Thanks and Regards

S. A. Yusuf Sithik.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firewall settings in RHEL 5.0 jpmaxyusuf Linux - Server 3 09-13-2008 10:03 AM
Firewall` script problem in RHEL 4 s_hcl Red Hat 1 06-05-2008 10:31 AM
Mounting an NFS volume on RHEL 5 Thru the Firewall louisb Linux - Server 7 10-05-2007 02:02 PM
tomcat5 error in RHEL-5 sachin1361 Linux - Enterprise 1 10-02-2007 05:33 AM
firewall error? couldn't load target "accept ...ipt_accept? error piratebiter Linux - Security 1 09-19-2003 06:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration