LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   firestarter gives me this error (https://www.linuxquestions.org/questions/linux-software-2/firestarter-gives-me-this-error-106570/)

shanenin 10-20-2003 11:52 PM

firestarter gives me this error
 
I am trying to get a working firewall enabled with slackware. I installed firestarter. It needs to be run from root. I get this error when I try to run it
-------------------------------------------------------------
root@marsala:/home/shane# firestarter
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(firestarter:1527): Gtk-WARNING **: cannot open display:
root@marsala:/home/shane#
-------------------------------------------------------------------
If I remember this is the same error I get if I run other programs as root, which normally I don't need to..

1. why can't I run it from root?

2. is their an easy way to get a working firewall without firestarter? I feel the need to get somthing working right away.

mcleodnine 10-21-2003 12:10 AM

that's because X will only allow connections from the user that is running X (you're starting the script as root) . to change this you could (as the regular user) run 'xhost +' to allow all connections to x server. make sure to disable this ASAP and read up on the risks in 'man xhost'


All times are GMT -5. The time now is 06:54 AM.