-   Linux - Software (
-   -   Firefox's "Open Containing folder" option not working ! (

RazorT4 07-20-2010 09:59 AM

Firefox's "Open Containing folder" option not working !
Hi, I just installed slack 13.1 and found that when I very first time ran Firefox and downloaded something of the net, and in that download pop up window clicked "Open containing folder", a dialog box poped up asking "this links needed to opened with an application, choose application", I don't know the exact wordings but you can look at it yourself
I thought there was some problem with the installer so using removepkg I uninstalled Firefox, downloaded it again in tar.bz2 format, extracted, and from the folder it was extracted to, I run the using bash, then when I downloaded something in this Firefox, I got the same error as in screenshot, this time too, when selecting the "Open containing folder".
So can anyone tell me what's this going on? And How can I solve it ?

RazorT4 07-20-2010 12:23 PM

Hi, since no one really replied I thought if you anyone here (administrator, moderator etc.) thinks this thread can be moved to slackware forums, only if they think so.
I felt like this cause its more kinda slack specific issue. may be.
But anyway, hey everyone I still need help ! Please.

GrapefruiTgirl 07-20-2010 12:28 PM


this is a good place for the question, since this issue occurs on other Linuxes also, but if you'd like it moved to Slack, no problem, just say so.

Meanwhile, there are a few LQ threads on this subject, one or more of which I have posted in myself, where one or more solutions are given. The solution I use is a little script in /bin or /usr/bin which launches Konqueror for the "Open Containing Folder" button, and a couple of configuration options in Firefox's about:config page to make it work. I should be able to locate at least one of these threads, and I'll post you a link here shortly (once I find it/them).

GrapefruiTgirl 07-20-2010 12:34 PM

OK, here's link #1, where I put details of my solution for using Konqueror from Firefox:

Note in post #7 on that page, there is a link leading to yet another page with maybe some more on this subject (I think it's called "Making Firefox aware of KDE apps).

Here's another great resource you should check out for loads of Firefox tweaks & settings:

And there's yet another page somewhere, which discussed launching GNOME applications such as Nautilus from Firefox, but I haven't got that link handy; if you end up wanting it and can't find it yourself, I'll have another look for it.

Best of luck :)

RazorT4 07-21-2010 04:38 AM

That did the work.

GrapefruiTgirl 07-21-2010 04:56 AM

Great! Glad you got it sorted.

marquisor 10-02-2010 11:51 PM

same issue here!

"Open" and "Open containing folder" are exactly the same!
tried the fixes in about:config. deleted mimeTypes.rdf. didn't help...

where are the options for the cases "Open" and "Open containing folder"??

for viewing the folder where it's saved i added Thunar as application, but it shows up for BOTH options, too. that's not it.

GrapefruiTgirl 10-03-2010 07:05 AM

@ marquisor,

maybe it's a good idea to start a new thread about your specific situation since this one is solved, and because it appears that this thread's ideas didn't help you fix yours. :)

Your situation might be a little different than the one in this thread, so in your new thread, please tell us what OS you're using too (looks like Slack 13.1 ?), and tell us what exactly you've tried so far to try to fix it.

Best regards!

marquisor 10-03-2010 07:36 AM

well it's exactly same distro as first post (13.1) and all fixes tried mentioned here. would be repetitive.. *shrug* ok not the shellscript..
bugtracker firefox says something similar, but in other distros it's working fine, dunno what's missing there... so it's not a need for a selfmade script i guess, it's an integration problem.

All times are GMT -5. The time now is 09:59 AM.