LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox (sometimes) starts in a non-maximized window (https://www.linuxquestions.org/questions/linux-software-2/firefox-sometimes-starts-in-a-non-maximized-window-4175495562/)

taylorkh 02-19-2014 05:49 PM

Firefox (sometimes) starts in a non-maximized window
 
I am not sure if this is a Firefox, CentOS 6.5 or Gnome issue but here it goes...

I always use Firefox in a maximized window. At least it is always maximized when I exit the program and usually it starts maximized. On occasion - and I cannot reproduce this behavior at will - Firefox will start in a non-minimized window. In these instances it seems to size itself so as not to interfere with other open windows.

This happened tonight. By way of investigation I left the small window Firfox running and copied my Firefox profile (which is not stored under my home directory) and my entire home directory to a backup drive. I then maximized Firefox and copiet the two items to a separate directory on the backup drive. Using one of my favorite utilities - Beyond Compare - I examined the two snapshots of data. The ONLY difference was the presence of the file startupCache.8.little in the Firefox profile taken after I maximized the window.

Can anyone offer a clue why Firefox (or Gnome or ???) sometimes forgets that Firefox was maximized when last used?

TIA.

ken

jamison20000e 02-20-2014 11:08 AM

Hi. It definitely interacts with other windows there should be window geometry or interaction settings some where (try combining through your systems settings?) I get rid of gnome and use KDE here you can right click on title bar and go to special window or application settings... could also while in Firefox hit the [F11] key for full screen mode (and to exit or move mouse to top ;)) if you exit in full screen it will stay on restart. Best wishes and have fun. :)

taylorkh 02-20-2014 11:20 AM

Thanks jamison20000e,

I used to use KDE some years ago. I got away from it when it began to have some strange permission issues back around Red Hat 8 or 9. I have sort of gotten used to Gnome 2 and have no desire nor need to move to anything else (at least until support for CentOS 6 ends in 2020). In Windoze I could create a shortcut (launcher) and tell it to run maximized. Gnome contains no such option that I can find. This is only an occasional issue. More a curiosity than a show stopper.

Again, thanks for your reply!

Ken


All times are GMT -5. The time now is 06:22 AM.