LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   firefox: segmentation fault (https://www.linuxquestions.org/questions/linux-software-2/firefox-segmentation-fault-769342/)

J_Szucs 11-15-2009 05:23 PM

firefox: segmentation fault
 
Firefox 3.0.0.15 on my opensuse 10.0 suddenly will not start ("segmentation fault"). The reason is unknown to me, since there was no sofware installation, update or reconfiguration for days before the fault occured the first time. (As a matter of fact, it used to crash often, but it could always be started so far).

What I tried and did not help:
- removing firefox and xulrunner and installing various versions (2.x through 3.0.x)
- removing all plugins
- renaming the $HOME/.mozilla directory

Strangely enough, it was able to start once, when I was logged in via ssh, but never since.
Seamonkey worked when it was installed as a replacement for firefox (but who knows, maybe just because I started it via ssh, too).

What can be the reason why firefox will not start, and how to correct it, if reinstallation and/or removal of its plugins and the .mozilla directory do not work?

MS3FGX 11-15-2009 05:39 PM

It seems like if older versions don't work either it must be some library issue, but then you say you haven't updated or changed anything...

Are you starting Firefox from the terminal? Does it give any more output than "segmentation fault"? How about starting in safe mode?

When you installed the different versions, how did you do it? Did you get the official binary releases from the Mozilla site, or where you using OpenSUSE packages? You might want to try grabbing the binary package from the Firefox site and extracting that into your /home directory.

J_Szucs 11-15-2009 06:09 PM

Sorry, but that system is OFF and inaccessible to me at the moment (hence I did not post the exact error message), but I will post it tommorrow.

I still started the thread as I hoped that the fact that it could be started once (with all plugins in place) when logged in via ssh (X forwarding) but it cannot be started (neither from the terminal, nor using the menu, or desktop icon) when logged in directly into that system may be a key alone to find the culprit.

I of course tried safe-mode, with no success, either. Tried "firefox -P" too, the profile selection window appears for a moment, then it disappears.
By the way, there is an other error message "/usr/lib/esd not found" before the one reporting the segmentation fault, but I doubt whether that error is fatal.
The different versions were installed from the opensuse repository.

MS3FGX 11-15-2009 06:20 PM

I would consider any error message or warning suspect when dealing with a segmentation fault, especially if there is no clear cause.

/usr/lib/esd is part of the Enlightened Sound Daemon not sure why that would start coming up as not found if you haven't made any software changes. You sure there wasn't an automated system update or anything like that? I'm not even sure why Firefox would be built against ESD actually, but I have never used OpenSUSE so I don't know specifically how they handle some things.

In any event, trying with the stock binary package from the Firefox site should tell you if the problem is in your system (and libraries), or some problem in your profile and user configuration.

J_Szucs 11-17-2009 01:11 AM

Problem solved ;)

When I could first login to the system directly (not over ssh), it turned out that firefox started normally, so reinstallation actually helped.

I only did not know that running gui softwares over ssh causes problems for opensuse nowadays. It used to work in the past.

I am really frustrated that many useful features that once worked stable are now made unreliable or missing in opensuse versions 11.x, whilst the new features are good for nothing.

Developers, I need no new features, so just please stop "developing" opensuse, and give me back my reliable opensuse 10.1! :)))


All times are GMT -5. The time now is 06:12 AM.