LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-24-2014, 03:13 AM   #1
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,958

Rep: Reputation: 271Reputation: 271Reputation: 271
Firefox reports 'The page isn't redirecting properly'


Beginning yesterday, Firefox started returning this error:

Quote:
The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.
for lots of sites, including LinuxQuestions.org and duckduckgo.

But I am accepting cookies from all. I've cleared the cache (by deleting the files with an rm -rf as well as CtlShiftDel in Firefox) and the cookies.sqlite file. I've also allowed tracking. I've done everything suggested at Mozilla's support site. Firefox 28.0. Latest Slackware, kernel 3.14.1 (build it myself).

I'm doing this in Opera.
 
Old 04-24-2014, 12:45 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Maybe the problem is somewhere in the Firefox configuration files. Rename your .mozilla directory (for example call it .mozilla.old) and then start Firefox again and see if the problem persists.
jdk
 
Old 04-24-2014, 02:59 PM   #3
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,958

Original Poster
Rep: Reputation: 271Reputation: 271Reputation: 271
Firefox has returned to working today as it did 3 days ago. I guess sleeping on it - I did nothing else - 'fixed' the problem.
 
Old 04-24-2014, 11:26 PM   #4
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
There are things that Man was never meant to understand (cue eerie music).
jdk
 
1 members found this post helpful.
Old 04-26-2014, 12:30 AM   #5
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,958

Original Poster
Rep: Reputation: 271Reputation: 271Reputation: 271
The URI in the address bar was from opendns, not the target domain; it may have been a defect in their records, perhaps something funny in its cache.
 
Old 04-26-2014, 10:13 AM   #6
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Yes, that usually happens when their (the target domain's) server is down.
jdk
 
Old 01-07-2015, 07:01 PM   #7
doug9694
LQ Newbie
 
Registered: Feb 2014
Posts: 15

Rep: Reputation: Disabled
I recently upgraded to firefox 34 from 17. I never received this message be fore. Gmail worked for awhile now I get the message continuously. What gives? I tried the on line help that says go to Tools > Options > Advanced > Network > Cached Web Content: "Clear Now",
Another says Tools/Options/Privacy - Click "Remove Individual Cookies"
Problem is that 34 does not have a "Options" in the "tools" menu. At least not in the 34
that I have. Where is the some thing in 34? Or has someone come up with a better fix?

Some how this got posted in another thread. I did find out that "Preferences" is the new
"Options" So I go to cookies and delete them. This works for a while. It comes back after
a while. The thread said this is "solved" I did not seer a solution other then keep going back into cookies and deleting. To me this is not a good solution. What is the permanent fix?
 
Old 01-07-2015, 11:44 PM   #8
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,958

Original Poster
Rep: Reputation: 271Reputation: 271Reputation: 271
Quote:
Originally Posted by doug9694 View Post
Problem is that 34 does not have a "Options" in the "tools" menu. At least not in the 34
that I have. Where is the some thing in 34? Or has someone come up with a better fix?

Some how this got posted in another thread. I did find out that "Preferences" is the new
"Options"'
This stuff is in tools/options in Firefox for Windows, edit/preferences in Linux. I think it's always been that way.

Quote:
Originally Posted by doug9694 View Post
So I go to cookies and delete them. This works for a while. It comes back after
a while.
Cookies? not cache? Does it happen for every site or just Gmail?

Quote:
Originally Posted by doug9694 View Post
The thread said this is "solved" I did not seer a solution
There was no solution. I marked it as solved to keep LQers from trying to help. 'Killed' would have been better but isn't a choice
 
Old 01-08-2015, 08:21 AM   #9
doug9694
LQ Newbie
 
Registered: Feb 2014
Posts: 15

Rep: Reputation: Disabled
Lightbulb Gmail, or other site, redirect problem

Quote:
Originally Posted by RandomTroll View Post
This stuff is in tools/options in Firefox for Windows, edit/preferences in Linux. I think it's always been that way.


Cookies? not cache? Does it happen for every site or just Gmail?


There was no solution. I marked it as solved to keep LQers from trying to help. 'Killed' would have been better but isn't a choice

I only use Puppy 5.6. And the Firefox 34 for linux. And it uses Edit/preferences to get into "History" then cookies. final is "Remove All Cookies" Tried to just delete gmail cookies.
That did not work. There must be another site that is leaving a cookie that messes up gmail???
Or there is a "*" icon on the tool bar that goes right to "History"
I used 17 before and had no problem. People with 28 and 31 had the same problem with gmail other sites .

Only gmail so far.

Is this not a help site? Why would you kill a thread that is trying to help others with a problem?. I am offering help in my post. Not a complete solution but at least I can now use gmail for a while. If I do find a solution I will post on this thread. If someone can find
the cookie that is causing the problem please post it so we all know. Or maybe there is another
solution.
 
Old 01-09-2015, 12:04 AM   #10
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,958

Original Poster
Rep: Reputation: 271Reputation: 271Reputation: 271
I have usually gotten excellent support from Mozilla's site.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The page isn't redirecting properly samr Linux - Server 4 01-22-2014 03:26 AM
Firefox prevented this page from automatically redirecting to another page. Aquarius_Girl General 1 07-26-2010 07:26 AM
Firefox window isn't displaying properly and crashes EllisDee Linux - Software 7 01-22-2010 05:41 PM
linux.com isn't rendering properly with Firefox dugan Slackware 13 05-25-2008 12:03 AM
[SOLVED] Firefox 1.5.0.4 isn't downloading properly in Mepis 6.0 MBA Whore MEPIS 3 01-03-2007 01:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration