-   Linux - Software (
-   -   Firefox not starting as a normal user (

fredgt 10-01-2004 07:36 PM

Firefox not starting as a normal user
Something strange is going on, i have recently installed suse 9.1 on my server (local ftp, http printing,...) and i was very pleased with it so i decided to change my desktop pc also from mandrake to suse. I got firefox working on the server but on the desktop it acts strange. I can't start it as a normal user but when is start is with "sudo firefox" as root it does work. Does anyone know what my problem is, am i missing any access to files i should have access to ?
I've tried different version and all have the same problem.

chrisbkillian 10-01-2004 07:55 PM

where is it installed?

fredgt 10-01-2004 07:56 PM

arne@linux:~> whereis firefox
firefox: /usr/bin/firefox /opt/MozillaFirefox/bin/

standard installation from rpm, exactly the same as on the server

Bobmeister 10-01-2004 08:03 PM

Try running it from the command line after doing:
xhost +

to allow all users. After that, a key should allow a normal user
to run the program. SuSE will restrict a user on new applications
from using the xhost until THAT appication has been used once
giving him special permission. I don't profess to understand it,
but it usually works.

fredgt 10-01-2004 08:15 PM

I just tried it but it doesn't change anything.
I've just tried mozilla and that has the same problem

Andrew Benton 10-01-2004 08:21 PM

Firefox has to be run at least once by a user who has write permissions in the folder it is installed in. So you could either run it as root (just once) or
chown -R $USER_NAME /opt/MozillaFirefox
and then after you've run it once
chown -R root:root /opt/MozillaFirefox

I avoid the problem by installing it in my home folder.

fredgt 10-01-2004 08:24 PM

ok i've found the problem and fixed it, somehow the /home/user/.mozilla folder was property of 'root' and not of the user. Everything works after i changed the owner of the folder and subdirectories.

sboy 10-02-2004 02:56 AM

I'm having the same problem. Unfortunately the solution doesn't seem to work for me. I'm trying to run it on Fedora Core, and tried installing firefox into my home directory, but whenever I try to run it as a normal user Gecko opens up and give the following message



The file owner on all the files and subdirectories is the normal user. Any suggestions?

Andrew Benton 10-02-2004 06:30 AM

What build is it you're trying to run, is it a nightly build or the 1.0 release candidate? Also, are you trying with a clean profile (delete or rename the .mozilla folder in your home folder before you launch Firefox for the first time, it will create a new, default profile).

sboy 10-03-2004 11:27 AM

Okay, got it working, thanks for your help. I went in and deleted the ./mozilla directory and now it starts just fine every time. fyi, I'm running the 1.0 Preview Build. Thanks

All times are GMT -5. The time now is 07:02 PM.