LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-19-2016, 11:25 AM   #1
-Snake-
Member
 
Registered: Feb 2014
Location: /home/snake
Distribution: Archlinux and Debian
Posts: 56

Rep: Reputation: Disabled
Firefox not load html 5 video


Hello, im running a web server, in a page i have a few videos on html 5 videos, I can load perfect this videos with chromium browser but not with firefox/midori, because I think that is not server problem.

The page is this:

http://hispagnu.org/videos.html

Thanks.
 
Old 11-19-2016, 03:39 PM   #2
hal8000b
Member
 
Registered: Mar 2001
Location: UK
Distribution: Mint, Arch, Debian7
Posts: 194

Rep: Reputation: 23
It plays ok on Firefox 49.0.2 on Linux Mint.

Your video files are ogg format:

<source src="videos/stallman_preguntas.ogg" type="video/ogg">

So what you need to do is open firefox and in the address bar type:
about:config

This will show you the plugins available to firefox. On my system ogg
video is played with libtotem-cone.plugin so try installing totem-plugins
package
 
Old 11-19-2016, 04:41 PM   #3
-Snake-
Member
 
Registered: Feb 2014
Location: /home/snake
Distribution: Archlinux and Debian
Posts: 56

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hal8000b View Post
It plays ok on Firefox 49.0.2 on Linux Mint.

Your video files are ogg format:

<source src="videos/stallman_preguntas.ogg" type="video/ogg">

So what you need to do is open firefox and in the address bar type:
about:config

This will show you the plugins available to firefox. On my system ogg
video is played with libtotem-cone.plugin so try installing totem-plugins
package
Thanks for response.

Im using archlinux and i did install gstreamer and gstreamer plugins.

In about:config i have:

Code:
media.ogg.enabled;true
But it not work.

PD: In chromium works 100%, and firefox, the first video works fine, but the others did not.

Last edited by -Snake-; 11-19-2016 at 04:43 PM.
 
Old 11-20-2016, 07:40 AM   #4
hal8000b
Member
 
Registered: Mar 2001
Location: UK
Distribution: Mint, Arch, Debian7
Posts: 194

Rep: Reputation: 23
Sorry, my mistake, should have been

aboutlugins

Anyway, rebooted into Arch Linux and all videos play.
In Arch aboutlugins shows I have openH264 and libflashplayer
installed only.

Try running

pacman -Syu

see if it will pull in dependencies.
 
Old 11-20-2016, 12:41 PM   #5
-Snake-
Member
 
Registered: Feb 2014
Location: /home/snake
Distribution: Archlinux and Debian
Posts: 56

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hal8000b View Post
Sorry, my mistake, should have been

aboutlugins

Anyway, rebooted into Arch Linux and all videos play.
In Arch aboutlugins shows I have openH264 and libflashplayer
installed only.

Try running

pacman -Syu

see if it will pull in dependencies.
In aboutlugins i have only installed openH264 and flash player, i have archlinux full updated and not work, it's strange.
 
Old 11-21-2016, 02:37 PM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,250
Blog Entries: 10

Rep: Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160Reputation: 5160
archlinux, palemoon.

videos work, but somewhat glitchy/uncontrollable.

the first one freezes when i go fullscreen, i think the bitrate is just too large.

encode the videos in at least 2 formats, the html5 audio tag can then choose the best for the browser.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminating YouTube html video started with firefox in bash script julianvb Linux - Software 1 09-29-2014 02:54 PM
html image load ygloo Programming 3 09-16-2006 01:04 PM
Gambas - Load html file? LinuxSeeker Programming 0 08-19-2005 01:48 PM
[apache 2.0] can't get index.html to load fraggie Linux - Software 5 04-09-2005 05:55 AM
load index.html when only ...com/dir is entered onlinesnet Linux - Networking 1 09-18-2001 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration