-   Linux - Software (
-   -   Firefox launching a twin which soon disappears.. (

andy-k 09-06-2006 06:42 AM

Firefox launching a twin which soon disappears..
I'm getting a weird little thing with Firefox on my Kubuntu Dapper installation.

What happens is whenever i launch Firefox, which i do by pressing my quicklaunch button in the taskbar, it opens, but a second Firefox tries to launch simultaneously, which never actually does open.

Instead, it just says Firefox in the taskbar next to the loading hourglass icon, and the cursor turns into the bouncing Firefox icon as though it were loading another Firefox.

After say 20 seconds or so this unwanted Firefox simply disappears. The original Firefox i had intended to launch works as it should throughout this odd process.

Is this a Firefox thing or a Kubuntu thing?

kstan 09-06-2006 07:20 AM

can you run firefox in terminal see what is the return msg?

homey 09-06-2006 08:28 AM


What happens is whenever i launch Firefox, which i do by pressing my quicklaunch button in the taskbar
Are you being careful to only single click icons in the taskbar?

kstan 09-06-2006 11:00 AM

i think u get the point...

andy-k 09-06-2006 02:10 PM

If i do 'firefox' in a terminal there is no message. It just opens firefox and then goes onto the next prompt.

And i may be a spaz but i'm not double clicking quick launch icons, and certainly not every time i launch firefox.

Plus if i was two firefox's would launch and stay open, as opposed to one thinking about opening without doing so then disappearing.

I can't say i've experienced this with any other program other than firefox.

kstan 09-06-2006 08:55 PM

please check was is the path f your firefox, is it you write your own script with the name 'firefox' too inside ~/bin? if yes please check back the script

JBailey742 09-06-2006 09:22 PM

I get the same thing, and he's most likely "not" making a mistake. I only get that when I use firefox as well, don't notice it on anything else. Any other single click that I do opens only one. For firefox, it opens two. one never does open up. It just shows it's busy, then it jsut goes away.

this is certainly a glitch/bug

andy-k 09-06-2006 09:36 PM

Must be. I haven't done anything remarkable.

Downloaded the latest version from mozilla, used the safe and recommended manual install instructions to install and set as default.

This can't be a general linux firefox bug or everyone would have the same problem, so there must be something in our configurations that is causing this to happen.

But what?

kstan 09-06-2006 09:40 PM

i dont have the same problem on ubuntu (or kubuntu), can you try to login as another user see same problem occur?

andy-k 09-06-2006 09:42 PM

I can't as i'm running a single user system, but maybe JBailey742 can.

I've now noticed that the problem only occurs when you already have one or more instances of firefox open already.

So when launching the first firefox it never happens, but when launching more than one it happens every time.

Cara25 09-06-2006 10:03 PM

This happen to me when I upgraded my Firefox 1.0.6 to 1.5.4? You have have two paths installed to launch Firefox either in the command button on the quicklaunch or elsewhere. Find (search) the path that works the quickest and keep it, look (search) for the other launch path and delete it. Hope this helps !
Scott Nash

andy-k 09-07-2006 08:02 AM

Thanks Cara25 i've fixed it thanks to your tip. Turns out when i checked by launching multiple firefox's using other links of launching methods the problem didn't happen. It only happened when using the quicklaunch icon.

So all i did was delete the existing quicklaunch icon and drag another onto the taskbar that i knew worked fine. Now i'm not getting the problem anymore.

Cheers :)

All times are GMT -5. The time now is 10:08 PM.