LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-19-2014, 04:18 AM   #1
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Firefox/Iceweasel can't display slides in slide show.


Dramatis Personae: Iceweasel (24.5) and Firefox (29.0.1)
Webpage in question: http://www.independent.co.uk/arts-en...s-9393092.html

There are a series of slides. The mozilla browsers mentioned above show the first three slides and then block any further action. Clicking the right-arrow or the pictures below have no effect at all. Google Chrome and Opera work correctly with the same page. My GF's system also running Iceweasel (24.5) has the same problem.

Any ideas about what's causing this and what will fix it, if anything.
Thanks,
jdk
 
Old 05-19-2014, 04:36 AM   #2
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
I'm using Wheezy with Iceweasel 29.0.1 and the first set of slides all worked fine, after I got to Angelina Jolie (pic 10 of 50) in the 2nd group I stopped. It seems fine here, sorry I can't be of more help.
 
Old 05-19-2014, 05:59 AM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by k3lt01 View Post
I'm using Wheezy with Iceweasel 29.0.1 and the first set of slides all worked fine, after I got to Angelina Jolie (pic 10 of 50) in the 2nd group I stopped. It seems fine here, sorry I can't be of more help.
Thanks k3lt01,
I suspect it's one of my many installed extensions (AdBlock Plus, HTTPS-Everywhere, DoNotTrackMe, etc.) that's the culprit.
Any further info from anyone would be most welcome.
jdk
 
Old 05-19-2014, 04:17 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 19,398

Rep: Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991Reputation: 2991
I'd guess a script error but might be an ad next slide.

If you see slide two and it has an address line that has a 2 near the end you may try to put higher numbers in. In some cases you can see the next line in hover or info at bottom of screen as to what the next page is.

I can't see the page in question due to noscript.
 
Old 05-20-2014, 12:36 AM   #5
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Thanks,
If I start, not from slide 1, but from slide x (where x >= 3) then I can see slide x and x+1 but then it freezes after that.
Don't know if this is helpful but here's a chunk of the code from the script.
Code:
<div id="gallery-9393035" class="esi-gallery rendered" data-galleryid="9393035">

    <div class="esi-gallery-loading-div" style="display: none;"> … </div>
    <div class="esi-gallery-wrapper hide" style="display: block;">
        <div class="esi-gallery-dimmer" style="display: block; opacity: 0.7;"></div>
        <div class="esi-gallery-slides-container">
            <div class="esi-gallery-slides-title"> … </div>
            <span class="esi-gallery-slide-counter"> … </span>
            <div class="esi-gallery-slides-wrapper" data-defaultheight="575" style="height: 575px;">
                <ul class="esi-gallery-slides" style="width: 5720px; transform: translateX(-2200px);">
                    <li class="esi-gallery-slide" data-slide="0" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="1" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="2" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="3" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="4" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide active" data-slide="5" style="float: left; width: 440px; height: 575px; line-height: 575px;">
                        <img data-originalimageheight="2048" data-originalimagewidth="1424" alt="Cilla Black" data-src="http://www.independent.co.uk/incoming/article9394208.ece/alternates/w1024/Cilla-Black.jpg" src="http://www.independent.co.uk/incoming/article9394208.ece/alternates/w1024/Cilla-Black.jpg" style="height: 573px; width: 399.805px;"></img>
                    </li>
                    <li class="esi-gallery-slide" data-slide="6" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="7" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="8" style="float: left; width: 440px; height: 575px; line-height: 575px;"> … </li>
                    <li class="esi-gallery-slide" data-slide="
???
jdk

Last edited by jdkaye; 05-20-2014 at 12:41 AM.
 
Old 05-20-2014, 12:58 AM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,458

Rep: Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602Reputation: 2602
for sites like that , you need to disable
No-script
Ad Block plus
Ghostery
allow cookies to install
and some times turn back on "java script"
and for some turn off the default firefox "block pop up windows"
and so on

that is NOT something i would do , so that site will NOT be getting my business

Last edited by John VV; 05-20-2014 at 01:00 AM.
 
Old 05-20-2014, 02:19 AM   #7
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,455

Rep: Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301Reputation: 2301
Indeed, I just tried to see the slide show in Firefox 32 and I can't even get past the first slide even after allowing scripts from 18 different domains to run. I would put it down to a web designer more interested in generating click streams than producing a page that works. Pages like that are pretty much asking to become hosts to malware.

Edit: It doesn't work in Chromium in "incognito" (the only way I run it) so I think it's likely down to cookies.

Last edited by 273; 05-20-2014 at 02:21 AM.
 
Old 05-20-2014, 02:23 PM   #8
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
@John VV & 273
Thanks gentlemen. It's comforting to know that the problem can be replicated. The Indie is not my favourite nor even regular haunt so I can live without the click thingy.

BTW the Guardian isn't much better; I can't play any of the video's on that site. I get this message:
Quote:
Error loading plugin:
Plugin file not found
I suspect this is also due to my AdBlocker.
cheers,
jdk
 
Old 05-20-2014, 10:30 PM   #9
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,767
Blog Entries: 27

Rep: Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629
With Opera (with the Notscript add-on) I was able to view all of both sets of slides.

With Iceweasel (with the no-script "Allow all on this page" option selected), I duplicated OP's problem.

I'm running Debian Sid.
 
Old 05-20-2014, 11:06 PM   #10
k3lt01
Senior Member
 
Registered: Feb 2011
Location: Australia
Distribution: Debian Wheezy, Jessie, Sid/Experimental, playing with LFS.
Posts: 2,900

Rep: Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637Reputation: 637
Quote:
Originally Posted by frankbell View Post
With Opera (with the Notscript add-on) I was able to view all of both sets of slides.

With Iceweasel (with the no-script "Allow all on this page" option selected), I duplicated OP's problem.

I'm running Debian Sid.
What about Firefox in other non Debian systems, does that do the same thing?
 
Old 05-21-2014, 09:32 PM   #11
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,767
Blog Entries: 27

Rep: Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629
I was able to view all the slides in Firefox 24.5 on a new install of Mageia 4 both without noscript and with noscript set to "Accept All on This Page."
 
Old 05-22-2014, 12:26 AM   #12
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Hmmm. I don't think I have noscript installed. Can you remind me where the setting "set to 'Accept All on This Page.'" can be found.
Thanks,
jdk
 
Old 05-22-2014, 08:47 PM   #13
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 15,767
Blog Entries: 27

Rep: Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629Reputation: 4629
When noscript is installed and you go to a page with scripts, it be default will display a dialog along the bottom of the windows with an "Options" button. Clicking that button pops up a list. "Allow all on this page" is one of the options.

I first got script-blockers when Google bought "Mobi" and that awful Mobi dialog bar started to appear at the bottom of many newspaper sites (I'm a news junkie).
 
Old 05-23-2014, 01:51 AM   #14
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Thanks Frank,
Well assuming that Noscript is an add-on, I don't have it installed so it must be one of my other add-ons that's causing this behaviour.
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Iceweasel (Firefox) does not show PDF Envite Linux - Desktop 1 02-06-2013 06:15 AM
Firefox/Iceweasel - Image display options? felixk Linux - Software 3 11-17-2009 03:32 AM
Slide Show in OpenOffice TanSahara Linux - Software 0 06-26-2006 04:41 PM
Html slide show Guignol Linux - General 1 09-21-2005 03:01 PM
Slide Show screensaver dewcansam Linux - General 3 07-18-2002 04:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration