LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-03-2020, 06:29 AM   #1
linuxUser247
Member
 
Registered: Jan 2019
Posts: 58

Rep: Reputation: Disabled
firefox emoji are black and white


hello,

I am using Ubuntu 19.10 and Firefox 76.0.1 (64-bit) for Ubuntu. This question has been posted also in Mozilla Support forum here: https://support.mozilla.org/en-US/questions/1289525. I am going to cite solutions in both places.

Problem description

For Firefox on many websites emoji appear black and white instead of coloured. Same are coloured in Google Chrome.

Here is an example: https://en.wikipedia.org/wiki/List_of_emoticons

Supplemental Images all appear coloured, on Emoticons only 20% are coloured. This is what it looks like:

Detailed Information

Click image for larger version

Name:	Screenshot-from-2020-06-04-16-03-49.png
Views:	6
Size:	191.0 KB
ID:	33345

This is what appears in Firefox Debugging tools:

Code:
Fonts Used      DejaVu Sans
                DejaVu Sans Bold Oblique

                Noto Color Emoji
                Noto Color Emoji
The correct fonts are applied to emoji:

Code:
fc-match 'EmojiOne'
NotoColorEmoji.ttf: "Noto Color Emoji" "Regular"

Code:
fc-match 'EmojiOne Color'
NotoColorEmoji.ttf: "Noto Color Emoji" "Regular"


However, I think that DejaVu takes precedence over Noto. I tried to change that:


Code:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <alias>
    <family>serif</family>
    <prefer>
      <family>Noto Color Emoji</family>
    </prefer>
  </alias>
  <alias>
    <family>sans-serif</family>
    <prefer>
      <family>Noto Color Emoji</family>
    </prefer>
  </alias>
  <alias>
    <family>monospace</family>
    <prefer>
      <family>Noto Color Emoji</family>
    </prefer>
  </alias>

  <match target="pattern">
    <test name="prgname">
      <string>firefox</string>
    </test>
    <edit name="family" mode="prepend_first">
      <string>Noto Color Emoji</string>
    </edit>
  </match>
</fontconfig>
reloaded the fontcache and restarted firefox. It did not solve the problem.


I don't know how to further debug, I don't understand enough about font configurations. I would appreciate some help, thank you!

Further Related Information

The problem is not limited to FireFox, it is system wide. Affected software:

- Google Chrome : 100% emoticon not working at all
- Boostnote (Electron, React desktop application): 100% emoticon black & white
- Firefox: 80% emoticon black & white

Unaffected software:

- Mozilla Thunderbird
- Firefox Debugger (Inspector)

Then, I changed font priorities system wide. After the fix:

- Google Crome: all coloured emoticons
- Boostnote: all coloured emoticons
- Firefox: 80% emoticons black & white

Current progress - Summary

Quote:
By default firefox uses its own emoji font, namely "Twemoji Mozilla". You may try changing the value of 'font.name-list.emoji' in the 'about:config' page
"My 'about:config' uses Twemoji Mozilla. I changed it to Noto Color Emoji and restarted Firefox. It remains unchanged."

Quote:
What addons do you use?
"I restarted FireFox with Add-Ons disabled. With FireFox in safe mode the problem persists."

Last edited by linuxUser247; 06-06-2020 at 08:30 AM. Reason: add crosslink info
 
Old 06-03-2020, 11:55 PM   #2
sxy
Member
 
Registered: Aug 2019
Posts: 41

Rep: Reputation: Disabled
Hi,

What is your firefox version? I'm using the 68.8.0 esr version of firefox, and it works fine with emoji. By default firefox uses its own emoji font, namely "Twemoji Mozilla". You may try changing the value of 'font.name-list.emoji' in the 'about:config' page and see what happens then.
 
Old 06-04-2020, 07:43 AM   #3
linuxUser247
Member
 
Registered: Jan 2019
Posts: 58

Original Poster
Rep: Reputation: Disabled
I am using "Firefox 76.0.1 (64-bit) for Ubuntu". My 'about:config' uses Twemoji Mozilla. I changed it to Noto Color Emoji and restarted Firefox. It remains unchanged.
 
Old 06-04-2020, 09:59 AM   #4
Contrapak
Member
 
Registered: May 2019
Location: /home/
Distribution: Arch Linux
Posts: 165

Rep: Reputation: 60
Colorblindness, perhaps?
 
Old 06-04-2020, 10:07 AM   #5
linuxUser247
Member
 
Registered: Jan 2019
Posts: 58

Original Poster
Rep: Reputation: Disabled
redundant info, to be deleted...

Last edited by linuxUser247; 06-06-2020 at 08:15 AM.
 
Old 06-06-2020, 05:25 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,587
Blog Entries: 9

Rep: Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081Reputation: 4081
^that looks all coloured on my FF 76.0.1 (64-bit).
What addons do you use?
 
Old 06-06-2020, 06:46 AM   #7
linuxUser247
Member
 
Registered: Jan 2019
Posts: 58

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ondoho View Post
^that looks all coloured on my FF 76.0.1 (64-bit).
What addons do you use?
a few. All cookies and cache is deleted. I do not use any Firefox web account to synchronize settings.

I restarted FireFox with Add-Ons disabled. With FireFox in safe mode the problem persists.

The problem is not limited to FireFox, it is system wide. Affected software:

- Google Chrome : 100% emoticon not working
- Boostnote (Electron, React desktop application): 100% emoticon not working
- Firefox: 80% emoticon not working

Unaffected software:

- Thunderbird
- Firefox Debugger (Inspector)

Then, I changed font priorities system wide. After the fix:

- Google Crome: working
- Boostnote: working
- Firefox: 80% not working

Edit: "not working" means no colour.

Last edited by linuxUser247; 06-06-2020 at 07:18 AM.
 
Old 06-06-2020, 07:02 AM   #8
linuxUser247
Member
 
Registered: Jan 2019
Posts: 58

Original Poster
Rep: Reputation: Disabled
on a fresh installation of Ubuntu 16.04 in a Virtualmachine, out of the box the same problem can be observed. Same for a VM with Ubuntu 20.04, but it's not a fresh installation.

@ondoho, which OS are you using?

Last edited by linuxUser247; 06-06-2020 at 07:12 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Mozilla Firefox 50.0 Now Available for Download, Brings Built-in Emoji on Linux LXer Syndicated Linux News 0 11-14-2016 10:44 PM
LXer: Get ready for Middle Finger Emoji, aka Flipping The Bird Emoji LXer Syndicated Linux News 0 06-18-2014 05:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration