LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2009, 02:16 AM   #1
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Firefox: changing Work Offline default


Hi all,
I'm running FFx 3.0.5 on Debian Lenny and like many people before me, I am annoyed with the Work Offline setting being the default setting.
I have perused the previous threads on this topic and found two solutions:
1. shut off the Network Manager daemon
2. change the settings in prefs.js
I have shut down the Network manager but to no effect
The relevant setting in prefs.js is:
user_pref("browser.offline", false);

Any ideas on how I can change this setting to default to Work Online?
Cheers,
jdk
 
Old 01-29-2009, 07:37 AM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Try with deleting the .default folder in .mozilla.Log out/log in.
 
Old 01-29-2009, 08:43 AM   #3
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by alan_ri View Post
Try with deleting the .default folder in .mozilla.Log out/log in.
Hi alan,
I don't have any .mozilla.Log. I do have ~/.mozilla which has a folder called "Default" but nothing like what you wrote. My FFx installation is in /opt but it doesn't have anything like .mozilla.Log either.

Am I understanding you correctly?
Cheers,
jdk
 
Old 01-29-2009, 08:58 AM   #4
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
No,delete .default folder and then log out from the system and then log back in.
 
Old 01-29-2009, 01:57 PM   #5
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by alan_ri View Post
No,delete .default folder and then log out from the system and then log back in.
Thanks for the reply, Alan. I must be very thick but I'm not understanding you. I don't have a .default folder. I have this:
~/.mozilla/firefox/zqzrspcp.default
Is that what you mean? Can you give me the complete path of where you think this .default folder would be?

Thanks again,
jdk
 
Old 01-29-2009, 03:12 PM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I think alan_ri is referring to a file in /home/you/.mozilla/.default
Maybe post #2 should read:
Quote:
Try with deleting the .default folder in .mozilla
Log out/log in.
Most file-managers have an option to "Show hidden files". Enable it. Then go exploring (and deleting, carefully). Most .config files are automaticaly re-created with (sensible) defaults if you delete them and then restart the application, or logout then login again. Caution: YMMV. If in doubt, and you really care, backup before experimenting.

"Hidden files" in linux are any file that begins with a "dot" or "period" or "."

Edit: Make sure firefox isn't running when you do this, or your "deletion" may well be undone.

Last edited by tredegar; 01-29-2009 at 03:14 PM.
 
Old 01-30-2009, 12:29 AM   #7
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Thanks Trededgar,
As I've said before, I don't have a file or folder in ~/.mozilla called .default and yes I am aware that file names beginning with a dot are hidden files. That's why whenever I do a kde installation on a new system, the first thing I do is configure konqueror so that it shows hidden files. The closest thing I have to what alan_ri described is this:
Code:
~/.mozilla/firefox/zqzrspcp.default
or this
Code:
~/.mozilla/default
Thanks anyway, though.
Cheers,
jdk

Last edited by jdkaye; 01-30-2009 at 12:33 AM.
 
Old 01-30-2009, 04:43 AM   #8
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by jdkaye View Post
Code:
~/.mozilla/firefox/zqzrspcp.default
Try by deleting that folder.
 
Old 01-30-2009, 12:51 PM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Testing"
Posts: 6,116

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
It occurs to me that would be safer to move it somewhere else (like to your home) rather than delete it as you'll find that directory contains your bookmarks and other useful stuff that you may not wish to lose.
 
Old 01-30-2009, 11:20 PM   #10
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tredegar View Post
It occurs to me that would be safer to move it somewhere else (like to your home) rather than delete it as you'll find that directory contains your bookmarks and other useful stuff that you may not wish to lose.
That's my thinking exactly, Tredegar. I really doubt that will solve anything since I did try editing the prefs.js, the one configuration file that actually mentions the online/offline parameter. Anyway, I'll rename (rather than delete) the file and see what happens and report back.
Thanks again,
jdk
 
Old 01-30-2009, 11:41 PM   #11
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jdkaye View Post
That's my thinking exactly, Tredegar. I really doubt that will solve anything since I did try editing the prefs.js, the one configuration file that actually mentions the online/offline parameter. Anyway, I'll rename (rather than delete) the file and see what happens and report back.
Thanks again,
jdk
Total failure ... but interesting. Closing FFx and then changing the name of the ~/.mozilla/firefox/zqzrspcp.default folder and then restarting FFx causes FFx to believe there is another instance of FFx running and it won't restart.
Code:
ps -A | grep firefox
indicates that there is NO other Firefox process running. Restoring the ~/.mozilla/firefox/zqzrspcp.default folder allows Firefox to restart normally.

Back to square one.
Thanks again for your help.
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox 1.5 always loads in 'Work offline' mode giffbd Linux - Software 7 12-13-2010 08:13 PM
Work Offline always set in Firefox in 10.3 swampdog2002 SUSE / openSUSE 3 10-19-2007 08:40 PM
Work Offline always activated on Firefox startup shooters Linux - General 7 09-23-2006 04:24 PM
mozilla-firefox offline bong.mau Linux - General 2 06-09-2006 08:43 AM
Changing default browser from Firefox to Mozilla nappy501 Linux - Software 5 05-08-2006 05:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration