LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-29-2009, 03:52 PM   #1
shane25119
Member
 
Registered: Aug 2003
Location: Illinois
Distribution: Linux Mint XFCE
Posts: 653

Rep: Reputation: 53
Firefox Awesome Bar not working


Hi all-

Recently, the awesome bar (URL dropdown menu) in Firefox stopped working for me.

Usually it occurs after an extended period of inactivity, so if I wake up in the morning and start typing my zipcode to pull up the weather.com entry for my area, nothing will come up.

Sometimes, clicking the down arrow next to the URL before beginning to type in a URL or part of the page description will do the trick, but just sometimes.

At seemingly random intervals it will decide to work again.

I've searched Google and LQ- without any luck of finding this problem elsewhere- any suggestions?

Last edited by shane25119; 06-29-2009 at 05:42 PM.
 
Old 06-29-2009, 04:33 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I went to the Mozilla web site and searched the add-ons and extensions for "awesome bar". No results were found.

https://addons.mozilla.org/en-US/fir...me+bar&cat=all

So what is this awesome bar? Where did you obtain it?
 
Old 06-29-2009, 05:41 PM   #3
shane25119
Member
 
Registered: Aug 2003
Location: Illinois
Distribution: Linux Mint XFCE
Posts: 653

Original Poster
Rep: Reputation: 53
Awesome bar is the the URL bar feature whereby you can type page headlines in rather than URL to search for history. So, for example, with this page (since I have been to it before I can type 'Firefox Awesome.....' and then it will pop up in the dropdown menu.
 
Old 06-29-2009, 07:08 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Oh. Thanks for that information. I've been trying to get Firefox to stop doing that! I find it very distracting.

Couldn't find 'awesome' in about:config. Darn.

Last edited by stress_junkie; 06-29-2009 at 07:10 PM.
 
Old 06-29-2009, 07:51 PM   #5
shane25119
Member
 
Registered: Aug 2003
Location: Illinois
Distribution: Linux Mint XFCE
Posts: 653

Original Poster
Rep: Reputation: 53
You've been trying to stop that feature from working? Any success? I'm trying to get it to resume working.
 
Old 06-29-2009, 11:19 PM   #6
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Our little discussion inspired me to get that darned thing to stop. I started turning all sorts of things off in about:config. I finally found a setting that turned it off.

browser.urlbar.maxRichResults;0

I found it in about:config by entering urlbar in the search box. I'm guessing that you would want a number larger than zero in that setting.
 
Old 06-30-2009, 01:44 AM   #7
shane25119
Member
 
Registered: Aug 2003
Location: Illinois
Distribution: Linux Mint XFCE
Posts: 653

Original Poster
Rep: Reputation: 53
Hmmmm, mine was set to 12. However, I found a setting in the same place at browser.urlbar.autoFill which was set to false, I changed it to true... here's hoping this does the trick.
 
Old 06-30-2009, 08:26 AM   #8
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Yeah. 12 was the default value in my Firefox about:config.

You could save your bookmarks into an html file in $HOME, then delete the $HOME/.mozilla directory tree, then run Firefox, import your bookmarks, and see if the awesome bar started to work.

Advantages: quick and easy.
Disadvantage: might not restore the functionality.

I just made the change to MaxRichResults in three other user accounts' about:config. It did the trick turning the awesome bar function off so that's useful for those of us that hate that feature.

Last edited by stress_junkie; 06-30-2009 at 08:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox - search bar schneidz Linux - Software 2 03-03-2009 05:49 PM
Firefox 3 address bar hbar Linux - Software 1 06-16-2008 07:52 AM
Search bar on top of Firefox not working hugene Linux - Software 4 12-20-2007 10:37 AM
firefox address bar marsques Linux - Software 3 07-23-2004 09:37 AM
Firefox Title Bar Icon servo_fan Linux - Software 4 03-23-2004 10:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration