-   Linux - Software (
-   -   Firefox & Thunderbird Crash Using Print Option on Mandrake 10.1 (

theGerbil 12-30-2004 07:08 AM

Firefox & Thunderbird Crash Using Print Option on Mandrake 10.1
Hi all

I am using Firefox 1.0 and Thunderbird 1.0 on MandrakeLinux 10.1 and when selecting the print option Firefox or Thunderbird crashs shut dependant on which one I am selecting Print from.

If I run Firefox from a terminal window it captures the following message:

/usr/share/firefox-installer/ line 451: 6749 Segmentation fault "$prog" ${1+"$@"}

The error generated for Thunderbird is:

/usr/lib/mozilla-thunderbird-1.0/ line 451: 6653 Segmentation fault "$prog" ${1+"$@"}

This happens 100% of the time and each time the error message is identical each time though the number before the text "Segmentation fault" changes. I have used Firefox and Thunderbird on many distros and never had this issue. I have tried both the Mandrake distributions and the generic RPMs from the Mozilla web-site.

Can anybody help please.

tfofurn 01-04-2005 11:42 AM

Same behavior with Firefox 1.0 on Fedora Core 1
I experience the same thing with Firefox 1 on Fedora Core 1. I've tried to submit bug reports through the crash feedback agent, but I have no idea if it gets through or not.

theGerbil 01-04-2005 11:56 AM


I have been looking at the thread at

" > Forums > Linux - Distributions > Mandrake > NewbieQ:Firefox/Thunderbird crash on startup (Mandrake 10.1)"

It's not your distro but it may have some pointers for you .. also it doesnt say whether anything worked but you may be interested to have a look.

Good luck!!!

the Gerbil

theGerbil 01-05-2005 12:46 AM

I managed to resolve this .. simple resolution in my case.

I didn't actually have a working printer defined. Once I defined a CUPS printer then the problem went away.

Shame there's no error trap for that kind of scenario.


tfofurn 01-05-2005 09:50 AM

Yes! The environment variables!
Thank you! At first I couldn't imagine what you meant. I'm in a corporate environment with dozens of CUPS queues at my disposal. I even run the CUPS daemon on my local machine so I can create profiles for secret printers. The problem was either the LPDEST or PRINTER environment variable, both of which were set to the same value: a printer that no longer existed. I replaced both with the name of a still-valid printer, and now it works. Huzzah! Hopefully they'll fix it to either generate a nice error message or (better yet) bring up a printer selection dialog when the printer doesn't exist.

theGerbil 01-05-2005 04:01 PM

Well, you sound as though you have a lot more experience than me and a lot more printers as well. I'm glad my little pointer was enough to get you on the road to success.



All times are GMT -5. The time now is 10:48 PM.