LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Software (http://www.linuxquestions.org/questions/forumdisplay.php?f=2)
-   -   firefox and searchplugins (http://www.linuxquestions.org/questions/showthread.php?t=276480)

sterrenkijker 01-11-2005 07:18 AM

firefox and searchplugins
 
Hi everybody,

I'm deeply ashamed asking such a foolish question, but I really can't figure it out...

When I try installing a searchplugin it just doesn't install. I click on the link on eg mozdev.mycroft.org and click on the OK button, and I don't see the new engine between my search engines. After restarting firefox I still don't see it. Mostly I also cannot find it in my .mozilla/searchplugins directory or /usr/local/firefox/searchplugins. Once I did find the wikipedia plugin files in .mozilla/searchplugins, but they weren't visible in firefox. Moving them to /usr/local/firefox/searchplugins/ solved it.

I'm using the official dutch mozilla build from mozilla's homepage. I used to use the debian build, but it has (had) no dutch version and I had trouble with the debian search engine: the icon sometimes disappeared so I couldn't choose a search engine anymore.

Does anyone know what I'm doing wrong, or if it is some kind of bug? Do others have similar problems? Installing a searchplugin shouldn't be that difficult...

Thanks,

Corien

XavierP 01-11-2005 07:24 AM

Moved: This thread is more suitable in Linux-Software and has been moved accordingly to help your thread/question get the exposure it deserves.

andrewlkho 01-11-2005 09:05 AM

So you're saying that it's in neither of the searchplugins directories? If not, then it wasn't properly installed. You need two files of the same name (dfferent extension) - one an image file (effectively a favicon), and the other a .src file which details how the search box works. If it's neither of your searchplugins directories, then it's not been installed properly.

It could well be a permissions issue. If the files are there, make sure you can read them. If it's not installing properly, then make sure you can write to that directory. I would suggest chmodding 777 just to be on the safe side, and trying again (you can reset the permissions once you've installed it).

sterrenkijker 01-11-2005 10:14 AM

It's definitely not that. I tried it but it didn't work.

I discovered another strange thing: I tried installing some extensions, but they don't install: they appear in the extensionslist with the message it will be installed after I restarted firefox. After restarting firefox they are still like that. When I try deinstalling them the just stay their with the message they will be deinstalled after restarting firefox, but they are not deinstalled... It's about "download statusbar" and "disable targets for download".

Really strange, plugins used to work... I installed several (like mousegestures and sessionsaver).

jonr 01-11-2005 11:07 AM

I suggest saving your current Firefox and relevant ~/.mozilla directories under another name just in case things go even more wrong than they are now, and reinstalling Firefox to see if that solves the problem. More than once I've saved myself time when Firefox started acting strange, by doing that.

sbassett 01-11-2005 11:35 AM

I would have to agree with jonr. If you had a build of Firefox before, was it built in /usr/local/firefox? I have heard of several instances where 2 different installs (even after one has been removed) in 2 different locations botching up firefox's plugin and extension capabilities. Try, as jonr suggested backing up .mozilla/ into another directory and remove the firefox install and try again.

sterrenkijker 01-11-2005 03:57 PM

I did that and it helped indeed. But I've done it before. Maybe it's some kind of a bug, just instability. It's still quite a new browser...

Thanks for the replies.

jonr 01-11-2005 04:10 PM

Quote:

Originally posted by sterrenkijker
I did that and it helped indeed. But I've done it before. Maybe it's some kind of a bug, just instability. It's still quite a new browser...

Thanks for the replies.

My impression from using Firefox since the days when it was still called Phoenix, is that there are indeed instability issues
with every version I've used. As a result I feel a bit uneasy about how hard Firefox is being pushed as a replacement for Internet
Explorer... I'm afraid a lot of people are going to try it, find it doing unexpected things, and say, "That's that!" and return to
IE.

I use Firefox, and Linux, because I simply will not patronize Microsoft ever again voluntarily. But many people don't have
that particular motivation, and it's a shame if they miss out on a more SECURE browser because of imperfections in it....

Anyway, glad you got your problem solved.

chrisj804 01-24-2005 03:42 PM

hi,

I just had the same problem (unable to install search plugins) with Firefox 1.0 on FC3. Fixed it by setting write permission for one of my groups on /usr/lib/firefox-1.0/searchplugins. I didn't like using the system wide directory for what is really a personal preference, but couldn't find a directory under $HOME that Firefox would use. I tried creating a directory called "searchplugins" in ~/.mozilla, ~/.mozilla/plugins, ~/.mozilla/firefox and ~/mozilla/firefox/<profile> but to no avail. Is this supposed to be possible?

Chris

jonr 01-24-2005 03:55 PM

(I posted here something I discovered immediately after posting was wrong! I said Firefox had its own personal prefs. directory. I was thinking of Thunderbird. I've always felt Firefox OUGHT to have such a directory. Sorry if anybody gets mislead during the few moments the bad post was up.)


jonr 01-24-2005 04:04 PM

OK. Now I've got it straight. My search plugins obtained and installed from Mycroft are in ~/Firefox/searchplugins. And that's where I have to go when I want to delete one for some reason.

I have had no trouble at all getting them installed; just point and click. I had a bunch of duplicates one time and it was easy to uninstall them by just deleting the "[filename].src" and "[filename].png" file for each one.

chrisj804 01-26-2005 03:19 PM

Firefox on FC3 doesn't appear to look for ~/Firefox/searchplugins - by default anyway. There must be some way to tell ffx where to look for a local searchplugins dir, just haven't found how to do that yet.

Chris


All times are GMT -5. The time now is 05:23 PM.