LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   firefox and debian (https://www.linuxquestions.org/questions/linux-software-2/firefox-and-debian-211566/)

snu 07-30-2004 02:31 PM

firefox and debian
 
Servus

I try to get firefox run by debian.
However when i want to start it i as user itget th errorcode

Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server

(firefox-bin:1169): Gtk-WARNING **: cannot open display:

As root everything is alright and it start.
It also starts when i type
xhost +

But this should not be a solution. Has someone an idea?

I tried
xhost + name
but i got the error message bad hostname. If this would work i could rite a startup script an everything is alright.
Hope you find a solution

Thanx
snu

Sul 08-18-2004 11:31 AM

I'm having the same problem with SuSE 9.1, and with thunderbird as well. I've searched google and this forum but I whatever has been suggested doesn't seem to work..

darkleaf 08-18-2004 02:50 PM

I solved it by moving my home folder somewhere else or doing something else with it but I can't remember the command. However I found the solution by copying the error in google. I found this bit which might have the solution it's from the debian mailing list but it's about the X FAQ:

Quote:

Instead, browse /usr/doc/X11/FAQ, paying particular attention to the
question labeled: "How do I run an X client as root when the X session
is run by a user?" Or, if you want all the gorey details, read the
xauth(1x) man page.

metroweasel 08-18-2004 08:39 PM

I think I had the same problem, first about a week ago, and again about ten minutes ago. Thunderbird would not launch after I restarted X for some reason. I don't know what caused it, and truthfully, I have no idea how I fixed it initially because I was trying to fix something else.

This time, however, I used the shell and ran:
Code:

mozilla-thunderbird -verbose
.

To my surprise, it launched. I have no idea why. None whatsoever.

Running debian unstable, mozilla-thunderbird version 0.7.3 (20040818)


All times are GMT -5. The time now is 05:35 AM.