LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Firefox Add-ons install but don't show up after restart, 'preferences' not working (https://www.linuxquestions.org/questions/linux-software-2/firefox-add-ons-install-but-dont-show-up-after-restart-preferences-not-working-604990/)

mbvpixies78 12-06-2007 01:07 PM

Firefox Add-ons install but don't show up after restart, 'preferences' not working
 
I tried to install the newer Firefox (2.0.0.11) but it didn't work. Then I went back to 2.0.0.8 and when I tried to install all my old add-ons from Windows into Linux, they install as usual but never show up after reboot, except in the Tools > add-ons box, where the 'preferences' button doesn't work. My weather add-on never showed up at the bottom of the browser, neither did the bookmarks add-on, nor stumble-upon, nor firebug, etc. etc.... I tried removing and reinstalling them to no avail. I removed and reinstalled Firefox through 'Install and Remove Software from the Menu but I'm still having the same problem. Help? Thanks.

b0uncer 12-06-2007 01:21 PM

I'd try to install the plugins directly from Mozilla's site, they should work at least. It does sound like there's something bigger wrong with the browser, though, if the new version won't install. I'm not sure which OS you're working on with that, but you should maybe try to remove all Firefox versions along with their configuration files (on Debian-based distributions, 'apt-get remove --purge packagename'), clean package cache (to make sure the new package is downloaded so it'll be 'fresh') and try to reinstall. Of course you can download the gzipped tar of Firefox from Mozilla, extract it somewhere and use that, but using your distribution's package manager might be more pleasant..

I haven't tried with Firefox, but it could give more clues if you started it from a terminal, and took a look at the possible errors thrown there.

mbvpixies78 12-06-2007 02:29 PM

Quote:

Originally Posted by b0uncer (Post 2982387)
I'd try to install the plugins directly from Mozilla's site, they should work at least. It does sound like there's something bigger wrong with the browser, though, if the new version won't install. I'm not sure which OS you're working on with that, but you should maybe try to remove all Firefox versions along with their configuration files (on Debian-based distributions, 'apt-get remove --purge packagename'), clean package cache (to make sure the new package is downloaded so it'll be 'fresh') and try to reinstall. Of course you can download the gzipped tar of Firefox from Mozilla, extract it somewhere and use that, but using your distribution's package manager might be more pleasant..

I haven't tried with Firefox, but it could give more clues if you started it from a terminal, and took a look at the possible errors thrown there.


Hmm... it deleted my response, which was:

I'm using Mandriva and it seems, from googling, that urpmi is the equivalent of apt-get, however, in the -help listing, there's no mention of anything to delete all the configuration files. Is there some other command I should use? How do I clean the package cache?

When I deleted firefox, restarted the computer and reinstalled it, all the add-ons I'd previously installed were already in the new installation (!?) and not working at all. I then uninstalled them and it restarted the browser itself and when I went to the add-ons box it listed them all as in the process of being deleted and needing a Firefox restart, as though it had never shut down. I am noticing now that Firefox puts an icon of itself in the bottom right taskbar (minimized) when I try to close it, and then it's an extra step to actually close it for good.

How can I get add-ons to work?

mbvpixies78 12-07-2007 01:36 AM

I went into "Install and Remove Software" in the menu and searched for Firefox, then clicked on "Files" to see the list of all the directories and files it installs and I used this list to find all the locations where files might be left over and I deleted them all before reinstalling Firefox. This didn't work. An old add-on that was installed (but never worked) on the previous, supposedly deleted installation was already there when the new installation was complete, though completely missing from the browser visually.

Is there a command I can use to delete any files associated with this package but which aren't accounted for in the list of folders I checked?

mbvpixies78 12-07-2007 02:11 AM

Resolved
 
I found out that there's a hidden .mozilla folder inside /home/[username] and once I chose View --> Show Hidden Files I was able to delete the entire .mozilla folder so that it was recreated during install and that got rid of the problem altogether. Whoo hoo


All times are GMT -5. The time now is 09:33 PM.